Menu
Download Free Trial

CSV Export not showing all filters across top, Excel showing no filters

When exporting a table to CSV with multiple filters across the top, the CSV file will only include the number of columns relevant to the table, which means not all the filters are being exported.
I have attached an example where there are three filters applied in the top row, but when it is exported to CSV (See “Csv File.png”) – only two of those are showing.
In Excel (see “Excel File.png”), there are no filters showing.
 
Is there a way to change these two things?

Thanks
 
Are either of these things possible to change?
 

1 answer

Public
Dmytro Zvazhii Flexmonster May 23, 2017

Hello Ashleigh,
Thank you for providing us with the screenshots. If you want to turn on the filters in exporting, please use the exportTo() API call (http://www.flexmonster.com/api/exportto/) with the showFilters attribute set as true. It will look like the following:
flexmonster.exportTo("excel",{showFilters: true })
The same thing can be done for CSV.
Please let us know if everything works fine for you.
Best regards,
Dmytro.

Please login or Register to Submit Answer