Menu
Download Free Trial

How to support classic layout for huge data?

6 answers

Public
Manoranjan Gahana July 20, 2017

When we have more columns then pivot is not supporting classic form.Its giving warning message “Too many columns for classic form. Switched layout to compact form.” How to resolve this issue ? Please find the attached image .

Attachments:
classic_layout.png

Public
Roman Petrusha Flexmonster July 21, 2017

Hi Manoranjan,
This message appears when there is not enough room for the scrollable content on the grid. To avoid such situation you have the following options:

  1. Increase the size of the HTML container for the pivot component.
  2. Resize some columns on the frozen area of the grid to left more space to the scrollable area.
  3. Decrease number of fields in the slice
  4. Use compact form instead of classic

Regards,
  Roman

Public
Manoranjan Gahana July 21, 2017

W can not use compact . we required only classic as per some client requirement.
Could you please give some example on this ?

Public
Roman Petrusha Flexmonster July 21, 2017

Manoranjan,
If the compact view is not an option you still have three other options to apply. Did you try any of them?
Please note that this limitation is not the bug but was made intentionally to make the user experience more smooth and comfortable. Otherwise, the scrollable area becomes too narrow and make end-users frustrated.
Thanks,
 Roman

Public
Manoranjan Gahana July 21, 2017

we tried all above option .Could please give some example to implement below option

  1. Increase the size of the HTML container for the pivot component.
  2. Resize some columns on the frozen area of the grid to left more space to the scrollable area.
Public
Dmytro Zvazhii Flexmonster July 21, 2017

Hello Manoranjan,
1. Increasing the size of the container means that you can increase the component width so it can take 100% of the available space. Please have a look here – http://www.flexmonster.com/doc/how-to-create-js-pivottable/.
2. Speaking about resizing the columns, the component allows resizing the columns width manually. As a workaround, you can set all the columns width so they could fit the available size and then save the configuration to the report. The report will include the information about the columns size so you can use it next time. Please have a look at the example – https://www.screencast.com/t/5cjOQYWkm1GR.
Let us know if everything works fine for you.
Best regards,
Dmytro.

Please login or Register to Submit Answer