Menu
Download Free Trial

Localhost

During our implementation of the flexmonster accelerator we have enoutered an issue. We are not able to communicate with the accelerator on localhost.
When we configure the client with a domain name and a port opened from outside there are no problems.
But when we ask the same request on localhost the flexmonster accelerator does not respond even though it is running.
You can find the log below.

<0> [root@river bi 18:35:15]# wget localhost:50006/Handshaking
--2017-07-24 18:35:24-- http://localhost:50006/Handshaking
Resolving localhost... ::1, 127.0.0.1
Connecting to localhost|::1|:50006... connected.
HTTP request sent, awaiting response... 404 Not Found
2017-07-24 18:35:24 ERROR 404: Not Found.

Thank you in advance for the quick reply, we need flexmonster ready for presentation reasons as soon as possible.

4 answers

Public
Dmytro Zvazhii Flexmonster July 25, 2017

Hello Radek,
Thank you for your question. We have noticed that you are trying to ping the accelerator with “wget” command using the console. Please follow the next steps to resolve the issue:
1. Run the accelerator URL, for your case it is http://localhost:50006. If everything is okay you should see something like this: 
 
Flexmonster Data Speed Accelerator for Pentaho Mondrian
 
Proxy URL: http://localhost:50006
 
2. Connect to the Flexmonster accelerator with Flexmonster Pivot. You can find all the examples here – http://www.flexmonster.com/doc/getting-started-with-accelerator-mondrian/.
 
The accelerator does not respond to GET requests. It communicates with the component using POST requests.
Please let us know if everything works fine for you.
Best regards,
Dmytro.

Public
Dmytro Zvazhii Flexmonster July 25, 2017

Hello Radek,
1. It seems that you need to add the “binary”: true property, the configuration will look like the following:

report: {
    dataSource: {
        dataSourceType: "mondrian",
              
        /* URL to the Data Speed Accelerator */
        proxyUrl: "http://localhost:50006",
 
        /* Data Source Info */
        dataSourceInfo: "MondrianFoodMart",
 
        /* Catalog name / Mondrian schema */
        catalog: "FoodMart",
 
        /* Cube name */
        cube: "Sales",
 
        // Flag to use Data Speed Accelerator instead of XMLA protocol
        binary: true
   }
}

 
2. Yes, it does. The Flexmonster Accelerator supports Flexmonster Pivot Component starting from version 2.2. All the specifications you can find here – http://www.flexmonster.com/doc/getting-started-with-accelerator-mondrian/.
3. There are no options to force the authentication in HTML component. In such cases we recommend using the approach described here – http://www.flexmonster.com/doc/configuring-usernamepassword-protection-mondrian/.
Please let us know if everything works fine for you.
Best regards,
Dmytro

Public
Tomas Botek July 25, 2017

Hi Dmytro,
thanks for the answer, but I have no idea how to force the Flex client to add binary in there. I have just the FlexPivotComponent, which generates requests by itself, I can not modify it. The example you have sent is for HTML client, but I am using FLEX client (means Actionscript). The component accepts licence key, endpoint but that is all.
 
What I did – I have opened the flex demo app, pressed connect button in the bar and afterwards pressed connect to the default address and then the Flex/Actionscript app listed dimensions and so (form default endpoint, which is http://olap.flexmonster.com/olap/msmdpump.dll ).
Later on, I found out, that the options in the connect toolbar are preconfigured as defaults in the javascript code of the toolbar.
So I guess the report classes in the demo (see bellow) are equivalents to theJSON you have sent for HTML/Javascript client? Are the keywords same in the XML config (it looks like type is a parameter of the element but filename is child element and I do not know, which attribute belongs where).
 
Thanks a lot,
Tom

Start you<config>
<dataSource type="CSV">
<browseForFile>false</browseForFile>
<filename>../data/data.csv</filename>
</dataSource>
<defaultSlice>
<axes>
<axis name="rows">
<hierarchy sort="asc">
<dimensionName>[Country]</dimensionName>
<hierarchyName>[Country].[Country]</hierarchyName>
</hierarchy>
<hierarchy>
<dimensionName>[Measures]</dimensionName>
<hierarchyName>[Measures]</hierarchyName>
</hierarchy>
</axis>
<axis name="columns">
<hierarchy sort="asc">
<dimensionName>[Color]</dimensionName>
<hierarchyName>[Color].[Color]</hierarchyName>
</hierarchy>
</axis>
</axes>
<hierarchies/>
<measures>
<measure aggregation="sum">[Measures].[Price]</measure>
<measure aggregation="sum">[Measures].[Discount]</measure>
</measures>
</defaultSlice>
<view/>
<conditions>
<condition measure="[Measures].[Discount]">
<![CDATA[if(AND(#value > 2000, #value < 4000), 'trueStyle')]]>
<trueStyle><![CDATA[{"backgroundColor":"0xff9966","fontSize":"13","fontFamily":"Tahoma","color":"0xffffff"}]]></trueStyle>
<falseStyle><![CDATA[{}]]></falseStyle>
</condition>
</conditions>
<format name="currency">
<param name="decimalPlaces">3</param>
<param name="maxDecimalPlaces">2</param>
<param name="columnDecimals">false</param>
<param name="maxSymbols">20</param>
<param name="currencySymbolAlign">left</param>
<param name="thousandsSeparator"><![CDATA[ ]]></param>
<param name="decimalSeparator"><![CDATA[.]]></param>
<param name="currencySymbol"><![CDATA[$]]></param>
<param name="nullValue"><![CDATA[no value]]></param>
<param name="infinityValue"><![CDATA[Infinity]]></param>
</format>
</config>r code here

 

Public
Dmytro Zvazhii Flexmonster July 26, 2017

Hello Tomas,
Sorry for misunderstood. Please try the following configuration:

<config>
    <dataSource type="mondrian">
        <catalog>FoodMart.xml</catalog>
        <cube>Sales</cube>
        <proxyUrl>http://localhost:50006</proxyUrl>
        <binary>true</binary>
    </dataSource>

 
    <defaultSlice>
    </defaultSlice>    
    ...
</config>

Let us know if it works for you.
Best regards,
Dmytro.

Please login or Register to Submit Answer