Menu
Download Free Trial

sort in combination with page filter not working

Resolved

Hi,
 
I have 2 default report configs:

slice: {
 rows: [
   { uniqueName: ‘monthString’ }
 ],
 columns: [
 {
   uniqueName:’demandChannelName’
 }
 ],
 pages: [
  { uniqueName: ‘onTime’, filter: { members: [‘onTime.[Late]’] } }
 ]
}

 
=> filter works fine

slice: {
 rows: [
  {
    uniqueName:’serviceItemName’
  }
 ],
 columns: [
  {
     uniqueName:’demandChannelName’
  }
 ],
 pages: [
   { uniqueName: ‘onTime’, filter: { members: [‘onTime.[Late]’] } }
 ],
 sorting: {
   column: {
     measure:’plannedWorkload’,
     tuple:”,
     type:’desc’
  }
 }
},

=> filter doesn’t get applied
 
In my opinion this should just work, am I missing something?

5 answers

Public
Iryna Kulchytska Flexmonster April 13, 2017

Hi Tijs,
 
Thank you for your question.
 
We tried to reproduce the bug you described with the newest 2.313 version and we cannot reproduce it. Please let us know the version of the component in what you experience this issue.
Also, we have noticed that the measure is missing in the slices you provided.
Could you please check if the slices contain the measure, as follows:

slice: {
  rows: [
  {
    uniqueName:’serviceItemName’
  },
  {
uniqueName:’[Measures]’
}
],
  columns: [
  {
      uniqueName:’demandChannelName’
  }
 ],
  pages: [
   { uniqueName: ‘onTime’, filter: { members: [‘onTime.[Late]’] } }
  ],
measures: [
{
uniqueName:’plannedWorkload’,
}
],
  sorting: {
    column: {
      measure:’plannedWorkload’,
      tuple:[],
      type:’desc’
  }
  }
}

Also, in the latest version tuple in sorting is Array. But this is not critical since string values are supported in terms of backward compatibility.
 
Could you please update the component to the latest version? If the issue is still there please provide us with steps to reproduce.
 
Kind regards,
Iryna

Public
Tijs Planckaert April 14, 2017

Hi Iryna,
 
I updated to the latest version and adapted the report like you suggested
 

{
"dataSource": {
"data": []
},
"options": {
"configuratorActive": false,
"viewType": "charts",
"chartType": "bar_stack"
},
"slice": {
"measures": [
{
"uniqueName": "plannedWorkload"
}
],
"rows": [
{
"uniqueName": "serviceItemName"
},
{
"uniqueName": "[Measures]"
}
],
"columns": [
{
"uniqueName": "demandChannelName"
}
],
"pages": [
{
"uniqueName": "monthString",
"filter": {
"members": [
"monthString.[2017M05]",
"monthString.[2017M06]",
"monthString.[2017M07]",
"monthString.[2017M08]",
"monthString.[2017M09]",
"monthString.[2017M10]"
]
}
}
],
"sorting": {
"column": {
"measure": "plannedWorkload",
"tuple": [],
"type": "desc"
}
}
},
"formats": [
{
"decimalPlaces": 2
}
]
}

However it’s still not working..

Public
Tanya Gryshko Flexmonster April 14, 2017

Hello Tijs,
Thanks for your reply. Everything works just fine on our side. Could you please tell us if this issue is reproducible on our website demo? In case your report works fine on our demo, we would be grateful if you shared your sample data with us. Also, we have one more suggestion. Please apply report filtering and sorting on the grid, save the report and open it again. We hope this way everything will work.
Regards,
Tanya

Public
Tijs Planckaert April 15, 2017

Hi Tanya,
 
The data is quite extensive and sensitive, could you perhaps provide a sample of the data you use where it does work?
 
I can try to see if it works here.

extra hint, on the exact same data, this works fine:

{
"dataSource": {
"data": []
},
"options": {
"configuratorActive": false,
"viewType": "charts",
"chartType": "bar_stack"
},
"slice": {
"measures": [
{
"uniqueName": "plannedWorkload"
}
],
"rows": [
{
"uniqueName": "monthString"
}
],
"columns": [
{
"uniqueName": "demandChannelName"
}
],
"pages": [
{
"uniqueName": "onTime",
"filter": {
"members": [
"onTime.[Late]"
]
}
}
]
},
"formats": [
{
"decimalPlaces": 2
}
]
}
Public
Tijs Planckaert April 15, 2017

Hi,
 
By looking at my configs I just put here I noticed the problem, somewhere in our code we accidentally overwrite the first filter.
 
Thanks for the help! Sorry to take your time 🙂

Please login or Register to Submit Answer