Menu
Download Free Trial

Subquery don’t work using microsoft analysis services.

I’m using a subquery like this link https://www.flexmonster.com/blog/how-to-use-subquery-parameter-for-faster-data-loading/ but not filtering.The Flexmonster Accelerator Manager Log MDX querys every change, but it’s not using the subquery.my code:
     “dataSource”: { “dataSourceType”: “microsoft analysis services”,
     /* URL to the Data Speed Accelerator */
     “proxyUrl”: “https://myserver.com.br:50005/”,
     /* Catalog name */
     “catalog”: “My Cube”,
     /* Cube name */
     “cube”: “My Cube”,
     “subquery”: “select {[Dimension].[Property].&[Value]} on columns from [MyCube]”,
     /* Flag to use Data Speed Accelerator instead of XMLA protocol */
     “binary”: true
}

2 answers

Public
Dmytro Zvazhii Flexmonster January 5, 2017

Hello Eduardo Verri,
Thank you for your question. We’ve prepared for you jsFiddle example with subquery http://jsfiddle.net/flexmonster/ej8j4jmg/ . Is it possible to get access to “”:https://gtracs5homol.autotrac.com.br:50005/” or send us log file? It will help us a lot with the investigation of your issue.
Waiting for your feedback.
Regards,
Dmytro.

Public
Roman Petrusha Flexmonster January 6, 2017

Hi Eduardo,

Please check if you have the latest version of the accelerator tool because ‘subquery’ feature is available only from version 2.304. If you have the older version please download and upgrade to the latest one.

Regards,
  Roman

Please login or Register to Submit Answer