Menu
Download Free Trial

Measure names not visible when grand totals turned off

Answered

If grand totals are turned off, and the aggregated measures are above other dimensions in the column or row, then the subtotal columns for the measures will not be displayed regardless of whether subtotals are turned on or not. Once grand totals are turned on, they are displayed above the grand total columns for each measure. 
 
This can be seen in the following fiddle: http://jsfiddle.net/gx19nf3k/
Ideally, the headers would have the same structure when you swap “country” and “values” in the column hierarchy, looking the same as http://jsfiddle.net/Lvwcrg6m/ but with “Sum of Price” swapped with “Canada” and “Sum of Quantity” swapped with “USA.”
 
On a side note (this doesn’t affect us because we don’t want grand totals), when grand totals are turned on in this scenario, the grand total columns are seemingly duplicated with one at each measure column and one at the end under a “grand total” section. I assume that is not what other users would want, but as I said, that doesn’t affect us. http://jsfiddle.net/9tq5uqLx/ is what I’m talking about. I can see that it might be valuable if the measures were in the middle of the hierarchy, but when they are at the top, it seems unnecessary.

9 answers

Public
Iryna Kulchytska Flexmonster August 3, 2017

Hi Jaime,
 
Thank you for providing us with the detailed description of the issue when grand totals are turned off. It will be fixed in the minor release 2.323 (ETA – Aug 28). By that time the major version 2.4 will be released and this fix will be available there as well. Does this work for you?
 
Also, thank you for the note about the “grand total” section that seems unnecessary when the measures are at the top. The “grand total” section can be turned off for columns using options. But we will definitely discuss your comment internally with the team.
 
Please let me know if you have any further questions.
 
Kind regards, 
Iryna

Public
Jaime McDermott August 3, 2017

This is a common use-case for us, so I do wish it could be fixed sooner. I suppose in the meantime we can either include grandTotals and then use a cell customize function to hide them or do the reverse and use a cell customize function to manually show them. If you happen to know of any easier workarounds off the top of your head, let me know.

Public
Tanya Gryshko Flexmonster August 4, 2017

Hello, Jaime,
Thank you for your feedback. Our development team will speed up the process of fixing the issue. The fix will be delivered as part of our next minor release 2.322 (ETA – Aug 14). We will inform you as soon as the fix is ready.
Regards,
Tanya

Public
Jaime McDermott August 4, 2017

Thanks so much!

Public
Dmytro Zvazhii Flexmonster 3 days ago

Hello Jaime,
I am glad to inform you that your fix is ready both for the minor release 2.322 and for the major 2.4 which are available for download now. 
You are welcome to update the component.
Kind regards,
Dmytro

Public
Sathish Srinivasan 2 days ago

I work with Jaime and it seems the problem is not completely resolved. We wanted to turn off the subtotals by default and now it seems the sub totals would always appear.
 
Flex monster config:
 
grand totals: off
sub totals: off
Measures reported as first thing in the columns
 
With these settings it seems the sub totals are always present irrespective of what settings are chosen.

Public
Iryna Kulchytska Flexmonster 1 day ago

Hello Sathish,

Thank you for providing us with the details of the issue.
I have created a sample that illustrates it: http://jsfiddle.net/flexmonster/3ys7Lrh6/

The component can be updated the way that when subtotals are turned off the highlighted cells will be empty (please see the image attached), but the structure of the table will remain the same.

Please let us know if it works for you and we will provide you with the ETA.

Kind regards,
Iryna

Attachments:
2017-08-17_1645.png

Public
Sathish Srinivasan 1 day ago

Hello Irynka,
 
I think thats fine for now. But could you please confirm if there are multiple attributes in the column then all the columns except the lowermost granularity expanded would be blank when subtotals is off?
Please find the attached screenshot with highlighted cells which I am thinking would be blank after your fix.
 
Also can you take this as a feature request where you would not display the blank cells too ?
 
Thanks,
Sathish

Public
Iryna Kulchytska Flexmonster 9 hours ago

Hello Sathish,
 
Thank you for providing the screenshot. I can confirm that if there are multiple attributes in the column then all the expanded columns would be blank when subtotals are off. Please note that if they are collapsed (not expanded), then numbers would be shown even if subtotals are off. Please see the screenshot attached.
Will this work for you? If yes, the fix will be included in the minor versions 2.323 and 2.402 (ETA – Aug 28).
 
We have added your feature request to not display the blank cells to our backlog, but there is no ETA for this feature.
 
Kind regards,
Iryna

Attachments:
2017-08-18_1631.png

Please login or Register to Submit Answer