Menu
Download Free Trial

Flat view sorting with multiple columns is not working.

Hi,
I tried to sort by column1 followed by column 2. once you apply the sort for one column, all other columns become random alphabetically.
it looks only allows to sort on one column and forgets any other column sorting. It should remember all sorting setup and apply those based on column position (first column first, then second column etc). It is working in pivot table classic layout but not in flat.
Please take a look and let me know whether able to recreate this or not. it’s happening in DEMO site also.
Thanks & Regards,
Sunilkumar.V

4 answers

Public
Ian Sadovy Flexmonster July 27, 2017

Hello Kumar,
 
You are right, it the flat view you can apply sorting only by one specific column at a time.
Otherwise, the data in rows will be messed up.
Do you have an example how it works in Excel or other similar software?
 
Regards,
Ian

Public
kumar July 27, 2017

Hi Ian,
Yes, the same way it works in Excel with custom sort option. Column 1 then after column2 then…column N.
Please find an attachment with an excel example: Without Sort and With Sort tabs. Please let me know if you need anything else.
 
Thanks & Regards,
Sunilkumar.V

Public
kumar July 27, 2017

Please find an excel example that I have attached.

Attachments:
Sorting.xlsx

Public
Tanya Gryshko Flexmonster July 28, 2017

Hello Sunilkumar.V,
Thank you for providing the Excel sample. Currently, sorting with multiple columns is not supported in flat view. This feature is not in our roadmap, however, we have added it to our customers’ wish list. We will keep you posted with any updates.
Regards,
Tanya

Please login or Register to Submit Answer