🍉 Meet Flexmonster Pivot Table & Charts 2.9.Check out all hot features!
Get Free Trial

A problem occurred after upgrading the version

Answered
Zander asked on May 17, 2021

Hello,
 
When I upgraded Flexmonster’s version from 2.8.7 to 2.8.31, the icon showed things that weren’t supposed to show up. 
 
Columns that I didn’t define in mapping won’t show up, but now they do.
 
How to solve it? Thanks.
 
Best regards,
Zander

4 answers

Public
Zander May 17, 2021

I could have hidden it use visible: false one by one, but it doesn’t make sense.

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster May 17, 2021

Hello,
 
Thank you for posting on our forum.
 
This feature was introduced in version 2.8.32. It allows adjusting mapping only for some fields while the rest have default settings.
We want to confirm that using the visible property is recommended to hide unwanted fields.
 
Regards,
Illia

Public
Zander May 17, 2021

Hi Illia,
 
I mean what should I do now to be compatible with 2.8.7?
 
There are many fields that I don’t need here, so it is not suitable to use visible.
 
So is there any other solution?
 
Regards,
Zander
 
 

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster May 18, 2021

Hello,
 
The only way to hide fields starting from version 2.8.32 is to set the visible property of the corresponding object to false.
Currently, there is no other approach to remove fields from the structure.
 
Regards,
Illia

Please login or Register to Submit Answer