I want to connect to Olap Cube from a different Server

I am not able to connect our SSAS Olap Cube from our Web Server. The connection is fine when both the cube and the flex monster are on the same Machine. 
Thanks,
Prince-Rene

11 answers

Public
Tanya Gryshko Flexmonster August 15, 2018

Hello, Prince-Rene!
Thank you for writing to us.
The first thing to check is whether a port for Accelerator is opened in the firewall. The opened port needs to match PORT parameter you set in flexmonster.config file.
If opening the port doesn’t help, could you please specify how you are connecting to your SSAS OLAP Cube? Also, please share with us which errors you are getting.
Waiting for your answer.
Regards,
Tanya

Public
Prince-Rene Azumah August 15, 2018

Thanks for the reply Tanya.  I opened both inbound and outbound ports on the Webserver but it didn’t help and I am not sure if I need to do anything on the OLAP Server. Kindly find attached the files I am using. The index file is how am connecting to the cube. This is just a test for our environment since we have the full flexmonster license. 
I put in a request for a call to the team yesterday but I haven’t heard from anybody yet. 
Thanks,
Prince-Rene 

Public
Prince-Rene Azumah August 15, 2018

Hello is anybody around? 

Public
Tanya Gryshko Flexmonster August 16, 2018

Hello, Prince-Rene!
Thank you for your patience. 
Could you please open DevTools(F12) in your browser and check if any error message there? Do you see any response from the server in the network tab?
Best regards,
  Tanya

Public
Prince-Rene Azumah August 16, 2018

Yes I see a HandShake error. 
Thank You,
Prince-Rene

Attachments:
HandShake_Error.PNG

Public
Tanya Gryshko Flexmonster August 17, 2018

Hello, Prince-Rene!
Thank you for providing the screenshot. In order to connect to your cube on another server, it is necessary to configure HTTP access to Analysis Services. This would require MSMDPUMP.dll configuration. For more details, you can refer to the guide from Microsoft
Please let me know if it helps.
Regards,
Tanya

Public
Prince-Rene Azumah August 17, 2018

Thanks Tanya. I have the configuration done so now what should I do with our Accelerator configuration and the Index file for Flex Monster? 
Sincerely,
Prince-Rene

Public
Prince-Rene Azumah August 17, 2018

Hi Tanya,
Kindly find attached the latest error I am getting when I set the proxyUrl in the index file as: 
proxyUrl:”http://localhost:5005/”
 
Thanks,
Prince-Rene 

Public
Dmytro Zvazhii Flexmonster August 20, 2018

Hello Prince-Rene!
Thank you for the additional details. Please make sure that you have successfully configured the roles on your cube: https://www.flexmonster.com/doc/configuring-authentication-process/. Also, you need to add the “binary” property when using Flexmonster accelerator: 

dataSource: {
        dataSourceType: "microsoft analysis services",
		// URL to a ccelerator
        proxyUrl: "http://localhost:50005/",
        catalog: "Adventure Works DW Standard Edition",
        cube: "Adventure Works",
        // roles from MSAS, you can add multiple roles separated by comma
        roles: "Sales Manager US",
// Flag to use Data Speed Accelerator instead of XMLA protocol
binary: true
}

Please note that by default the accelerator is started on the 50005 port.
Let us know if the information above was helpful for you.
Regards,
Dmytro
 

Public
Prince-Rene Azumah August 21, 2018

Thanks for email but I don’t find most of the emails as giving me the final solution- I sent an index file so I was expecting at least a feedback as to whether my index file was configured properly and how the accelerator configuration because my accelerator is running find with the ports I configured and I also I could connect on when everything is on the same box. We have a paid license and I also request a call but nobody is responding so I will have to talk to my manager about support for this product since I am not able to resolve the issue so far. 
Sincerely,
Prince-Rene

Public
Dmytro Zvazhii Flexmonster August 21, 2018

Prince-Rene,
First of all, I would like to stress that we are not your own support team. We have different time zones, so we can’t respond at any time when you need our help. Also, we have other clients and all of them want our attention. We are not magicians to fix any issue immediately. To avoid conflicts and misunderstandings I propose to respect each other.
Regarding your issue. You have to check:

  1. If opened inbound and outbound ports on the OLAP Server but not on the Webserver as you wrote previously.
  2. If the user on the server has enough rights as described in this article https://www.flexmonster.com/doc/configuring-authentication-process/
  3. If names of catalog and cube are correct.

Your index file is correct and we have the detailed manual how to configure Accelerator here: https://www.flexmonster.com/doc/getting-started-with-accelerator-ssas/ Please read it carefully, try recommended steps and if you still have a problem we will have a call.

Thanks,
 Dmytro

Please login or Register to Submit Answer