Loading Charts Fails Silently

Answered

Hey There!
When attempting to open a chart with 1 column, flexmonster will typically show an error dialog letting the user know that the data is not fit for charting. However, I have a report which simply fails silently when the user attempts to open a chart. The console error seems to indicate that flexmonster is trying to access a property on an undefined variable, but I can’t tell much more than that since it’s minified. I’ve attached a gif of this in action, which also shows the console error.

4 answers

Public
Corwin Sheahan June 7, 2018

Here’s the report I’m using (which was exported from flexmonster)

Public
Tanya Gryshko Flexmonster June 8, 2018

Hello, Corwin,
Our team would like to thank you for reporting this issue!
The update containing the fix will be released on June the 18th.
Please let me know if you have any other questions.
Regards,
Tanya

Public
Tanya Gryshko Flexmonster June 8, 2018

Corwin,
We would also like to mention, that if you turn on the grand totals (remove "showGrandTotals": "off" from the report or turn them on in the toolbar), charts will be shown as expected. Hope this can work for you as a temporary workaround until the fix is ready.
Regards,
Tanya

Public
Tanya Gryshko Flexmonster June 19, 2018

Hello, Corwin,
We are glad to inform you that the new version of Flexmonster has already been released. The issue with an exception when switching from flat view to charts was fixed.
You’re welcome to update the component.
Regards,
Tanya

Please login or Register to Submit Answer