Prevent Flat Form Default Sort

The attached screenshot shows data from the FlexCompressor (SQL Server).  The sql query has an “ORDER BY Brand, Model, ModelYear” but the Flat Form is overriding this and sorting by DateStart (the first column). 
I can manually sort by ModelYear, Model and then Brand, but it still does not give me the 3 layers of sort I need that the ORDER BY does (not ILX in the MODEL column screenshot is not alphabetical).  If I can’t have multiple layers of sort, is there anyway to have it not sort and preserve the order the data comes in – at least until the user does something like click sort or filter?

1 answer

Public
Tanya Gryshko Flexmonster March 21, 2018

Hello, Sandip,
Thank you for writing to us.
Multiple layers of the sort are not supported. We suggest preserving the order the data comes in without additional sorting. This can be done by setting defaultHierarchySortName option as "unsorted". By default, it is set to "asc". This option can be set in the report. For more details please refer to our tutorial: Options.
Please let me know if there is anything else I can help you with.
Regards,
Tanya

Please login or Register to Submit Answer