Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

trial period has expired Error with default key even after updating new key.

Answered
ASHUTOSH PANDEY asked on October 22, 2020

Getting trial period has expired Error , even after entering trial key in the flexmonsterpivottable.js file as suggested , Error Message comes with old default key only.

Attachments:
flexmonster.png

7 answers

Public
Milena Pechura Milena Pechura Flexmonster October 22, 2020

Hello, Ashutosh,
 
Thank you for posting to our forum and for providing a screenshot of the error.
 
Our team would like to mention that the license key may not be applied because of caching. To solve the issue, we kindly suggest deleting the ‘optimize’ folder at the root of Kibana.
Please follow the steps in this thread to delete the mentioned folder.
 
Could you please let us know if the suggested approach works for you?
Waiting for your reply.
 
Kind regards,
Milena

Public
ASHUTOSH PANDEY October 22, 2020

i went through the thread and deleted the optimize folder and retried i got new error this time not sure whats it about this time ?
Please be informed that i could not run 

yarn add flexmonster@2.7.3 –flat
yarn add react-flexmonster@2.7.3-1 –flat
 
because it gave me error Module not found.
 
Also in https://github.com/flexmonster/pivot-kibana/tree/v1.15 installation steps its not mentioned.
i did yarn update however that also was not successful.
 
yarn upgrade
yarn upgrade v1.22.4
warning package.json: No license field
warning ..\..\package.json: License should be a valid SPDX license expression
warning flexmonster_pivot@1.1.4: No license field
warning flexmonster_pivot@1.1.4: No license field
warning flexmonster_pivot@1.1.4: No license field
[1/4] Resolving packages…
[2/4] Fetching packages…
[3/4] Linking dependencies…
warning ” > react-flexmonster@2.8.18-1″ has unmet peer dependency “flexmonster@2.8.18-1”.
warning ” > react-flexmonster@2.8.18-1″ has unmet peer dependency “prop-types@^15.7.2”.
warning ” > react-flexmonster@2.8.18-1″ has unmet peer dependency “react@^16.8.1”.
warning ” > react-flexmonster@2.8.18-1″ has unmet peer dependency “react-dom@^16.8.1”.
[4/4] Rebuilding all packages…
error An unexpected error occurred: “EPERM: operation not permitted, open ‘C:\\Users\\ashu\\Downloads\\kibana-7.2.0-windows-x86_64\\kibana-7.2.0-windows-x86_64\\plugins\\flexmonster_pivot\\yarn.lock'”.
info If you think this is a bug, please open a bug report with the information provided in “C:\\Users\\ashu\\Downloads\\kibana-7.2.0-windows-x86_64\\kibana-7.2.0-windows-x86_64\\plugins\\flexmonster_pivot\\yarn-error.log”.
info Visit https://yarnpkg.com/en/docs/cli/upgrade for documentation about this command.
 
as version of Kibana as well as flexmonster are different i can not use as it is the steps in Thread mentioned by you above.
 
 

Attachments:
flexmonster2.png

Public
ASHUTOSH PANDEY October 23, 2020

Hi Milena Pechura,
 
Thanks for your support ,
Please check my reply above , licence issue is solved i guess but i got another issue after that .
Detailed information about it in my last message above.
Awaiting response from your side.
 
Regards,
Ashutosh

Public
Milena Pechura Milena Pechura Flexmonster October 23, 2020

Hello, Ashutosh,
 
We are happy to hear that the license issue is solved.
 
Please note that we have ceased the development of the plugin due to breaking changes made in each new release of Kibana. These changes mean that we can not guarantee maintenance for the different versions. Therefore, we kindly recommend using a direct connection to Elasticsearch for the testing of the Flexmonster features.
 
If it is needed to use the Kibana with Flexmonster:
According to our experience with the development of the Kibana plugin, the most relevant solution for your case will be the custom integration of Flexmonster with the version of Kibana you use. We suggest using our plugin’s code as a starting point.
 
Please let us know if any further questions arise.
 
Best regards,
Milena

Public
Milena Pechura Milena Pechura Flexmonster November 11, 2020

Hi, Ashutosh,
 
Hope you are doing well.
 
Our team would like to kindly take an interest in whether one of the suggested approaches works for you.
 
We would be happy to hear your feedback.
 
Kind regards,
Milena

Public
ASHUTOSH PANDEY November 13, 2020

Hi Milena,
 
Due to Bandwidth constraint we cant attempt to update the files of flexmonster to fix the issues , also as its mentioned that new versions of Kibana will not be supported however we have to update kibana and elasticsearch both. so this situation has kind of blocked any progress on pivot table part.
Thanks
 
Regards :-
Ashutosh

Public
Milena Pechura Milena Pechura Flexmonster November 16, 2020

Hello, Ashutosh,
 
Thank you for your feedback.
 
Please kindly note that Flexmonster Pivot can be used with Elasticsearch as a data source and without Kibana. With such an approach, you can easily update Kibana and Elasticsearch without any restrictions. Here are the corresponding article and demo for illustration.
Could you please let us know if this approach works for you?
 
Looking forward to your response.
 
Kind regards,
Milena

Please login or Register to Submit Answer