default format don't be saved if option active is false

long yu asked on June 11, 2019

hello :
my slice defaut like this :
slice: {
“reportFilters”: [
{
“uniqueName”: “Periode.Year”,
“caption”: “Periode.Année”
},
{
“uniqueName”: “Periode.Month”,
“caption”: “Periode.Mois”
},
{
“uniqueName”: “Periode.Day”,
“caption”: “Periode.Jour”
}
],
“rows”: [
{
“uniqueName”: “nom_operateur”,
“caption”: “Opérateur”
}
],
“columns”: [
{
“uniqueName”: “[Measures]”
}
],
“measures”: [
{
“uniqueName”: “nom_operateur”,
“caption”: “Opérateur”,
“active”: false
},
{
“uniqueName”: “heure”,
“caption”: “Heure”,
“active”: false
},
{
“uniqueName”: “temps_pause”,
“caption”: “Durée totale des pauses”,
“active”: false
},
{
“uniqueName”: “temps_pause”,
“aggregation”: “sum”,
“caption”: “Durée totale des pauses”
},
{
“uniqueName”: “hors_temps_pause”,
“aggregation”: “sum”,
“caption”: “Durée totale hors pauses”
},
{
“uniqueName”: “Durée totale de connexion”,
“formula”: “sum(\”temps_pause\”) + sum(\”hors_temps_pause\”)”,
“caption”: “Durée totale de connexion”
},
]
}
but when we export file JSON, we lose all the options “active : false”
could you help me plz ?
thank you
 

4 answers

Public
Dmytro Zvazhii Flexmonster June 12, 2019

Hello long yu,
Thank you for reporting the issue.
The described behavior does not look correct.
We have reproduced the case on our side and will provide a fix in a minor update with ETA Jul 15.
Please let us know if everything works fine for you.
Regards,
Dmytro

Public
long yu June 12, 2019

thanks a lot ! waiting for your update ! 🙂

Public
Tanya Gryshko Flexmonster July 16, 2019

Hello, Long yu,
 
We are pleased to inform you that the issue with not saving active: false measures was fixed.
 
This is provided in the 2.7.10 version of Flexmonster: https://www.flexmonster.com/release-notes/.
 
You are welcome to update the component: https://www.flexmonster.com/doc/updating-to-the-latest-version/.
 
Feel free to write to us in case of questions.
 
Best Regards,
Tanya

Public
long yu July 17, 2019

Hi Tanya :
I have already updated, it works well
Thank you ! 

Please login or Register to Submit Answer