Dear visitor, despite the COVID-19 outbreak, our team continues operating at full speed.

Also, here is the form where you can apply for a special discount and we will contact you with possible options. Stay safe and continue achieving your business goals.

Fill the form
Get Free Trial
Get Free Trial

Flexmonster v2.7.14 compatibility issues with IE 11

Answered
Kumar asked on December 20, 2019

Hi Team,
We are facing issues with Flexmonster v2.7.14 where it gives a promise undefined error with IE 11.
We tried degrading the version of Flexmonster to v2.6.15 and the issue was resolved.
We have been using some of the features of Flexmonster v2.7.14 – ‘mapping’ property. Could you please suggest some workaround to have the mapping property implemented with v2.6.15 or with a fix for promise undefined with Flexmonster v2.7.14 on IE 11.
Please let me know if you need any additional details from me.
Could you please also confirm if the typescipt version 2.7.10 is compatible with Flexmonster v2.6.15.
“@types/flexmonster”: “^2.7.10”

Many thanks,
Kishlay

4 answers

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 20, 2019

Hello, Kishlay,
 
Thank you for your question.
 
We would like to kindly inform you that our team did not manage to reproduce the problem on the latest version 2.7.21 of Flexmonster.
 
We recommend you to update your component to the latest version. Here is the documentation article on how to update it: https://www.flexmonster.com/doc/updating-to-the-latest-version/
 
Please let us know if it works for you.
 
Regards,
Illia

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 20, 2019

Hello,
 
As for @types/flexmonster, the version 2.6.2 would be the most appropriate variant for Flexmonster v. 2.6.15.
 
Regards,
Illia

Public
Kumar December 23, 2019

Hi Team,
Many thanks for replying.
I still am facing issues with IE for flexmonster v2.7.21. Could you please let me know the appropriate variant of ‘@types/flexmonster’ for flexmonster v2.7.21.

I am using this:    “@types/flexmonster”: “^2.7.12”

Sharing the error image for your reference.

~Cheers
Kishlay

Attachments:
IEerror.PNG

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 23, 2019

Hello, Kishlay,
 
Thank you for your feedback.
 
Version 2.7.12 of @types/flexmonster is the most appropriate variant for Flexmonster version 2.7.21.
 
We would like to kindly inform you that our team did not manage to reproduce the named issue. It would be useful for investigation if you could provide a sample demonstrating the problem.
 
Also, we would like to notice that polyfills have to be used in order to make the project work correctly in Internet Explorer 11.
 
Kind regards,
Illia

Please login or Register to Submit Answer