Get Free Trial
Get Free Trial

Problem to create charts with number fields

Answered
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI asked on June 7, 2019

Hi,
I’m having some problem to create a chart when all fields are Integer. (attach)
Flexmonster 2.7.7

Attachments:
problem.gif

13 answers

Public
Dmytro Zvazhii Flexmonster June 10, 2019

Hello Mario,
Thank you for writing to us.
 
We have not managed to reproduce the issue on our side. Please see the following JSFiddle example: https://jsfiddle.net/flexmonster/rkprvhhs/1255/.
Could you please modify the suggested example to describe the issue? The other types of samples where the issue is reproducible are also appreciated.
 
Waiting for the update from you.
Regards,
Dmytro
 

Public
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI June 10, 2019

Hello,
unfortunately I could not reproduce on jsfiddle, becouse I can’t edit the elasticsearch source data. But I have some more information on my enviroment, it’s only happening when have Zeros on the row side. 
I’ve tried to show on the attachment.
 
 
 

Attachments:
problem.gif

Public
Dmytro Zvazhii Flexmonster June 11, 2019

Hello Mario,
Thank you for providing us with more details.
 
We have managed to reproduce the issue with the charts and Elasticsearch data source on our side.
Our dev team will research the case and notify you with the result on ETA Jul 01.
 
Please let us know if everything works fine for you.
Regards,
Dmytro

Public
Vera Didenko Flexmonster July 2, 2019

Hello, Mario,
 
We are happy to let you know that the issue Elasticsearch and charts when zeros are in rows was fixed.
 
This is included in the 2.7.9 version of Flexmonster: https://www.flexmonster.com/release-notes/
 
You are welcome to update the component.
Here is our updating to the latest version guide for assistance: https://www.flexmonster.com/doc/updating-to-the-latest-version/                                                                                                                       
 
Feel free to write to us in case of questions.
 
Best Regards,
Vera

Public
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI July 8, 2019

Hi,
Now the zeros are just hidden. For me it’s not fixed.

Public
Vera Didenko Flexmonster July 9, 2019

Hello, Mario,
 
Thank you for your reply.
Your feedback is very important to us.
 
Our team has taken your point into consideration and we will provide a fix for this in the minor release with the ETA 12th of August.
 
Please let us know if you have further questions.
 
Best Regards,
Vera

Public
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI July 17, 2019

It’s a bit frustrating to wait two months for something so simple but so critical.

Public
Vera Didenko Flexmonster July 17, 2019

Hello, Mario,
 
Thank you for writing to us.
 
Having taken into account the importance of the fix, our team will try to speed up the process and include the fix in an earlier custom provided build.
We will provide it as soon as it is ready.

Would this work for you?
 
Thank you for your patience.
 
Best Regards,
Vera

Public
Vera Didenko Flexmonster July 18, 2019

Hello, Mario,
 
We are glad to inform you that the fix for the issue with zeros is ready.
 
Our development team has prepared a pre-release build with the fix: https://flexmonster.s3.amazonaws.com/rrs-software-ltda/FLEXMONSTER-2019-RRS-SOFTWARE-LTDA-JUL18.zip
 
We would like to mention that this fix will be officially included in the minor release with the ETA 29th of July.
 
Please let us know if everything works fine for you.
 
We are looking forward to hearing from you.
 
Best Regards,
Vera

Public
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI July 24, 2019

Hello Vera,
I`m doin’g something wrong here? 
Still not working. (attach)

Attachments:
capture.gif

Public
Vera Didenko Flexmonster July 24, 2019

Hello, Mario,
 
Thank you for your response.
 
According to your release build version, it seems the pre-release build we have provided is not being used.
The version shown on the screencast is Version 2.7.9 (build 07/01/2019 12:00:18), whereas the pre-release one is Version 2.7.10 (build 07/18/2019 14:36:51)
 
We kindly suggest updating your Flexmonster version carefully.
Here is a link to our updating to the latest version tutorial for guidance.
 
Please let us know if this helps.
 
Best Regards,
Vera

Public
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI July 24, 2019

Now it’s working. (browser cache)
Thx

Public
Vera Didenko Flexmonster July 30, 2019

Hello, Mario,
 
We are happy to let you know that the fix for the issue with a hidden “0” member for Elasticsearch is now included in the 2.7.11 version of Flexmonster: https://www.flexmonster.com/release-notes/.
You are welcome to update the component.
 
Please contact us in case any questions arise.
 
Best Regards,
Vera

Please login or Register to Submit Answer