Menu
Download Free Trial

Stream Error While Loading with olap

Answered

I am seeing a “Stream error occurred while loading https://site/file.xmla” what steps can I take to try and remedy this issue. 

6 answers

Public
Tanya Gryshko Flexmonster June 21, 2017

Hello Brody,
Thank you for writing. The most probable cause of this error message is incomplete CORS settings. Please open browser’s console, check out the errors here and configure IIS. For that purpose, we recommend the step-by-step guide with detailed instructions. Please let us know whether you managed to resolve the issue.
Regards,
Tanya

Public
brodybinks June 21, 2017

 Thanks for the response!
 
I have gone through the steps in that guide twice now and am still seeing the error. Is there anything else that could be causing the error?

Public
Tanya Gryshko Flexmonster June 21, 2017

Could you please tell us which errors do you get in the browser’s console?
Also, we recommend trying out our Flexmonster Accelerator for MS Analysis Services. It replaces XMLA protocol and uses direct requests from the Component to a server. The Accelerator transfers data faster and is easier to configure. Please have a look at the documentation: Getting started with Accelerator. We would be grateful for your feedback.
Regards,
Tanya

Public
brodybinks June 21, 2017

The error I see in the console is POST 401 (Unauthorized)

Public
Ian Sadovy Flexmonster June 22, 2017

Hello Brody,
 
Thank you for the response.
It seems that access to your OLAP server requires authorization.
Since there is no option to provide authorization headers via JavaScript, please consider using Flexmonster Accelerator for secure access to your data – http://www.flexmonster.com/doc/configuring-usernamepassword-protection/
 
Hope it helps.
 
Regards,
Ian

Public
brodybinks July 21, 2017

I received your answers, but have not been able to test the fix yet. I will update this thread when I am able to test the solution.

Please login or Register to Submit Answer