Need a special offer?Find out if your project fits.

Stream error occurred while loading "http://localhost:8080/olap/msmdpump.dll"

guest asked on July 24, 2015

When I try to connect to my OLAP, the component says stream load error.

Please let me know what is wrong? When I use your demo config file to connect to Flexmonster OLAP, it works fine.

4 answers

Ian Sadovy Ian Sadovy Flexmonster July 24, 2015

Hello and thanks for the request.

Javascript requires a number of special settings on the server. And below's the guide on it.

For cross-domain access, you need to specify the domains that will be allowed to make these data requests, the method through which data will be transferred, the fields that control what headers can be used in the requests, and, in case of authenticated access, indicate that user credentials need to be provided. All this is handled by configuring several HTTP responsehandlers.

The following steps demonstrate how to setup the IIS for accepting HTTP headers:

1. Access the IIS OLAP application

1.1 Connect to your server. Using a tool like Remote Desktop Connection, connect to your remote server where your application resides.
1.2 Launch the IIS Manager. Run the IIS Manager on the server.
1.3 Navigate to your IIS application. Using the IIS Manager interface, navigate to your application that is hosting the HTTP access provider (msmdpump.dll). In this case, you will be accessing the OLAP application.

2. Configure the HTTP Response Headers

In the application, add and configure the required headers:

Access-Control-Allow-Headers: Origin, Content-Type, Accept
Access-Control-Allow-Origin: *
Access-Control-Request-Method: POST

For the sake of this example, requests from any domain will be accepted (* for Access-Control-Allow-Origin); if you need to accept requests only from certain domains, then put the domain names in the place of the asterisk (*). For enabling anonymous access do not define the Access-Control-Allow-Credentials header.

To add and configure the headers:
2.1. In your application, in the Home pane, double-click HTTP Response Headers. The HTTP Response Headers module opens.
2.2. Add a custom HTTP response header.
       A. In the Action pane, click the Add … link. 
           The Add Custom HTTP Response Header dialog appears.
       B. Configure the header. In the Name field, type the name of the HTTP response header, e.g. Access-Control-Allow-Headers.
           In the Value field, type the desired value forthe HTTP response header, e.g. Origin, Content-Type, Accept.
       C. Click OK.
       D. Repeat steps A-C with the respective settings for the other headers.

3. Configure the OPTIONSVerbHandler

3.1. Access the Handler Mappings module. Navigate back to the OLAP application and double-click HandlerMappings.
3.2. Double-click the OPTIONSVerbHandler. The Edit Module Mapping dialog opens.
3.3. Allow Read access.
       A. Click the Request Restrictions button. The Request Restrictions dialog appears.
       B. In the Access tab, set the access setting to Read.
       C. Click OK. The Request Restrictions button dialog closes and you are taken back to Edit Module Mapping dialog.
       D. Click OK again. The Edit Module Mapping dialog now closes and you are taken back to the calling screen.
3.4. Make sure that OPTIONSVerbHandler is at the top of the Handler Mappings list.

To access the Handler Mappings, from the Actions menu, click View Ordered List…. The OPTIONSVerbHandler MUST BE AT THE TOP of the Handler Mappings list. If it isn’t, select the OPTIONSVerbHandler and use the Move Up command from the Actions menu to move it to the top. Please, check it after any modification you've made.

Hopefully this will be enough to make everything work properly.
Does it help?

Ian Sadovy Ian Sadovy Flexmonster August 17, 2015

Also, there is an article "Configure HTTP Access to Analysis Services on Internet Information Services (IIS) 8.0" on Microsoft TechNet portal.

Amit Shinde August 16, 2017

Hello Ian,
I am using 2.4 version of PIVOT MS Analysis services control. I followed instructions mentioned but still not able to connect to OLAP site.
It says handshaking required Cross Origin Resource Sharing (CORS). Can you please help ne with this?

Roman Petrusha Roman Petrusha Flexmonster August 17, 2017

Hi Amit!

The most popular source of the problem is a Handler Mappings module. 
Please check if OPTIONSVerbHandler is in the top of the list (see attachment).

Does it help?



Please login or Register to Submit Answer