Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

classic format not working properly

Resolved
Ravi Kumar asked on November 17, 2020

Hi,
I tried with COMPACT format, but the data is not getting rendered properly.
As you can see in the attachment, for all VENDOR_DESC it is showing all JOB_DESC, but it shouldn’t right?
 
Please provide any way to overcome this issue.
 
Regards,
Ravi

Attachments:
pivot (4).xlsx

5 answers

Public
Ravi Kumar November 17, 2020

Hi,
Please find the JSON Data & Flexmonster Data object

[
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”TRANSWORLD FOR MARKETING & TRADING”,
“amount”:15000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”SONU CONSTRUCTION COMPANY”,
“amount”:24000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”SONU CONSTRUCTION COMPANY”,
“amount”:24000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”SONU CONSTRUCTION COMPANY”,
“amount”:24000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”SONU CONSTRUCTION COMPANY”,
“amount”:24000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”SONU CONSTRUCTION COMPANY”,
“amount”:24000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”SONU CONSTRUCTION COMPANY”,
“amount”:10000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”TRANSSHIP SHIPPING LLC”,
“amount”:21500.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”Ford GBS”,
“vendor_Desc”:”TRANSPORT CORPORATION OF INDIA LIMITED”,
“amount”:38500.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”BUILDING & FACTORIES IC – CHENNAIBANGALORE CLUSTER”,
“vendor_Desc”:”SONU CONSTRUCTION COMPANY”,
“amount”:730000.0000,
},
{
“iC_Desc”:”Buildings & Factories”,
“job_Desc”:”PSG College-Hostel Block”,
“vendor_Desc”:”RAMASAMY S “,
“amount”:3682486.8600,
}
]
 

export const FLEXMONSTER_DATA_OBJECT = {
    dataSource: {
        dataSourceType: ‘json’,
        data: [],
    },
    options: {
        grid: {
            // title: ”,
            // showFilter: true,
            // showHeaders: true,
            type: ‘flat’,
            showGrandTotals: false,
            showTotals: false,
            // grandTotalsPosition: ‘top’,
            // showHierarchies: true,
            // showHierarchyCaptions: true,
            // drillthroughMaxRows: 1000,
            // showReportFiltersArea: true,
            // dragging: true,
            // showAutoCalculationBar: true
        },
        configuratorActive: false,
        // configuratorButton: true,
        // showCalculatedValuesButton: true,
        showAggregationLabels: false,
        defaultDateType: ‘date string’,
        datePattern: ‘dd-MMM-yyyy’,
        showEmptyValues: true,
        // editing: false,
        // drillThrough: true,
        // showEmptyData: true,
        // showAggregationLabels: true
    },
    slice: {
        rows: [],
        columns: [],
        measures: []
    },
    formats: [
        {
            thousandsSeparator: ”,
        }
    ],
    conditions: [],
    expandAll: true
};

 
 
Provide any way quickly, we’re running on tight schedule.
 
Regards,
Ravi

Public
Milena Pechura Milena Pechura Flexmonster November 17, 2020

Hi, Ravi,
 
Thank you for providing the dataset and report object.
 
We would like to kindly explain that the described behavior is caused by defining showEmptyValues: true. Please find the details about this property in the following article: https://www.flexmonster.com/api/options-object/.
 
Here are the explanations of Flexmonster logic when the previously mentioned showEmptyValues config is specified:
If there is no amount value for some job_Desc value in your dataset, the empty cell will appear in the amount column/row on the grid. Therefore, there will be an amount value for every job_Desc.
 
For your case, our team suggests specifying the showEmptyValues property as false
 
Hope it helps!
 
Best regards,
Milena

Public
Ravi Kumar November 18, 2020

Hi Milena,
Thanks for the quick response.
Above suggestion making showEmptyValues property as false is working for us.
Now we’re facing another problem, i added total 6 rows, 1 measure and no columns and applied with classic layout form, and we’re getting alert message that “Too many columns for classic form, changing to compact form“.
But according to our requirement we need to more columns in that case automatically layout is changing from classic to compact.
Please find the attachment and provide any solution.
 
Regards,
Ravi

Public
Milena Pechura Milena Pechura Flexmonster November 20, 2020

Hello, Ravi,
 
We are glad to hear that our suggestion works for you.
 
Speaking of the mentioned alert message, we recommend checking out the following forum thread:
https://www.flexmonster.com/question/too-many-columns-for-classic-form-switched-layout-to-compact-form/.
 
Hope it helps.
 
Best regards,
Milena

Public
Ravi Kumar November 21, 2020

Hi Milena,
Thanks for the response. Suggested way in the above thread suits to our requirement.
 
Regards,
Ravi

Please login or Register to Submit Answer