Column order changes when deselecting all columns from editor.

Answered

When deselecting all columns from “Fields Editor” in Flat view column order changes to different one than it was before.
 
Steps to reproduce the bug: In this fiddle https://jsfiddle.net/aivarsak/jcgf5rp8/ open  “Fields Editor” and uncheck “Select all”, then press apply. Result: column order has changed. Expected result – column order stays as it was before.
 
Best regards,
Aivars

3 answers

Public
Dmytro Zvazhii Flexmonster July 18, 2018

Hello Aivars,
Thank you for reporting this. When you deselect all the fields from the “Fields Editor” and press apply the empty slice is applied to the component. The empty slice behavior for the flat view when showDefaultSlice property is true (that property has the value true by default) is the following: the component will apply the default slice. The default slice for the flat view selects all the fields and sets the order which is equal to the fields order in the original data source. Therefore, the order is changed when you press the apply button.
However, the fact that the component allows setting the empty slice means that the behavior is not correct. We are going to add the necessary update which should deactivate the apply button when it is an incorrect slice in the “Fields Editor”, ETA Aug 13. The component should not allow setting an empty slice from the “Fields Editor”. The same behavior is in the compact and classic view.
Please let us know in case you have any other question.
Regards,
Dmytro

Public
Dmytro Zvazhii Flexmonster 6 days ago

Hello Aivars,
We are glad to inform you that the version with the fix has already been released. You are welcome to update the component.
Regards,
Dmytro

Public
Aivars 5 days ago

Thank you!

Please login or Register to Submit Answer