Get Free Trial

Console error in v2.9.19

Answered
Renier Lewis asked on January 13, 2022

We are trying to upgrade from Flexmonster version from 2.8.0 To 2.9.16 and that worked fine.
In the console we however noticed an error message.
Uncaught SyntaxError: Unexpected token ‘<‘ 
Flexmonster.toolbar.is72.9.9.1
We are unable to solve the above issue as it appears to be in the library to which we don’t have access.
Please can you guide us on how to troubleshoot the issue?
Thanks
Renier

Attachments:
FlexError.png

2 answers

Public
Nadia Khodakivska Nadia Khodakivska Flexmonster January 14, 2022

Hello, Renier,
 
Thank you for reaching out to us.
 
It seems that the issue is caused by the wrong flexmonster.toolbar.js file’s location. You can see it in the DevTools Network tab. To fix such an issue, we suggest trying these approaches:

  1. Check the URL where Flexmonster is getting the flexmonster.toolbar.js file and place the file into the necessary folder.
  2. Alternatively, connect flexmonster.full.js instead of flexmonster.js – it includes flexmonster.toolbar.js and all required libs in one JS file.
  3. One more option is setting the componentFolder property of the constructor – it should point to the folder with Flexmonster files on your server.

 
We hope it helps. You are welcome to write to us in case further questions arise.
 
Kind regards,
Nadia

Public
Renier Lewis 4 days ago

Thank you this resolved the problem!

Please login or Register to Submit Answer