Get Free Trial
Get Free Trial

data not loading in the pivot tool

Devesh asked on July 26, 2019

Hi team,
I am connecting pivot component in angular project with SQL/ .net database as mentioned in guide. The API is returning data in CSV format as I checked in response tab but it is not loading in the tool. I kept waiting for like 10 mins but still loading. PFB screen shot.
Please help.
Thanks

Attachments:
fm data loading.PNG

4 answers

Public
Vera Didenko Flexmonster July 29, 2019

Hello,
 
Thank you for writing to us.
 
It seems that the report may not be configured correctly.
 
We kindly advise ensuring that the report is configured correctly and checking the browser’s console for possible errors.
 
Could you please share your report with us as well as a screenshot of the browser’s console so we may be able to help you solve the problem?
 
Waiting for your reply.
 
Best Regards,
Vera

Public
Devesh July 29, 2019

Hi Vera,
I have attached report config and browser console screen shots. Although No error in console. I have followed the doc guide.
Please let me know if any issues in config.
And I checked this further and found that the issues is happening when I return and use CSV format.(I am following as guided in document for data compression and all.) Data is loading with JSON format.

Public
Vera Didenko Flexmonster July 30, 2019

Hello, 
 
Thank you for your reply and for sharing your configuration.
Your Angular configuration looks correct. In this case, the problem may be in the server-side script.
 
Our team has not managed to reproduce the issue on our end. 
 
Could you please provide us with a sample server-side script where the issue is reproducible? 
Any sensitive information can be sent via email.
 
This will help us a lot to understand the cause of the problem.
 
We are looking forward to hearing from you.
 
Best Regards,
Vera

Public
Devesh August 8, 2019

Thanks Vera !
Problem solved.

Please login or Register to Submit Answer