Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

Error: [parse_exception] failed to parse date field

Answered
Harish Reddy asked on December 23, 2019
[parse_exception] failed to parse date field [1453420800000] with format [date_hour_minute_second]: [failed to parse date field [1453420800000] with format [date_hour_minute_second]]

Following is the datetime field mapping in my index, which is working fine with kibana timelion but the same index at flexmonster is giving failed to parse the time format error as shown above.

"datetime" : {
"type" : "date",
"format" : "date_hour_minute_second"
}

GET my_index/_search
"datetime" : "2016-02-03T14:26:00",
...
...

I observed that, on fresh start of flexmonster, it seems to be working as you can see on the attached image, but on further changes, it fails. 
Please give me a solution

4 answers

Public
Dmytro Zvazhii Flexmonster December 24, 2019

Hello Harish,
Thank you for writing to us.
The described error message is the message returned by the Elasticsearch instance. It seems that the issue occurs on the Elasticsearch side.
Could you please specify what further changes you are performing? Also, could you please provide us with the queries Flexmonster send in such cases?
Waiting to hear from you.
Regards,
Dmytro

Public
Harish Reddy December 26, 2019

@Dmytro Zvazhii, Thank you.
The “datetime” field contains 1440  (at 1 minute interval) values in each day (unique date) and I have 60 days data, so the the  “datetime” field looks like the following for the day Jan 01 2016 (same for all days). 

2016-01-22T00:00:00
2016-01-22T00:01:00
2016-01-22T00:02:00
.
.
2016-01-22T00:59:00
2016-01-22T01:00:00
.
.
2016-01-22T23:59:00

But as I started flexmonster, in the “Fields” selection settings I have put “values” into “columns” and “datetime” field into “rows” and applied, the table has only 61 rows (one per each day along with the grand_total) instead of 1440 * 60 rows. The “datetime” column in the table displays only the 00:00:00 interval of each day as shown below (you can see in the above screenshots). Even in the filter setting for the “datetime”, I am able to see only 60 values i.e. 00:00:00 interval of each day. Though this is not what expected, I choose to filter the available datetime values but got the above mentioned error “failed to parse date field” and then whatever I do, I get the same error. 
In Kibana-Discovery the field seems working fine

2016-01-22T00:00:00
2016-02-03T00:00:00
2016-02-12T00:00:00
.
.
Public
Harish Reddy December 26, 2019

See this Kibana Discovery for the same index

Public
Ian Sadovy Flexmonster December 30, 2019

Hello Harish,
 
Thank you for the details.
We would like to explain that in Flexmonster datetime fields are aggregated with day interval by default. That is why you see the dates summarized only for 00:00:00. But it can be configured with a mapping property (see details at https://www.flexmonster.com/doc/configuring-the-mapping/). So you can use a 1 minute interval to aggregate the datetime column (find more about time units that can be used for the interval here https://www.elastic.co/guide/en/elasticsearch/reference/current/common-options.html#time-units).
 
Please let us know if it helps.
 
Regards,
Ian

Please login or Register to Submit Answer