Get Free Trial

Experiencing query parsing errors when using more than one filter

Answered
Miguel Duarte asked on February 11, 2021

Hello,
I am having issues applying multiple fields on the Filters. I am using SSAS Tabular (Power BI Premium) with the Accelerator.
When I use only 1 field on the Filters, all works well. As soon as I add a second filter and use it, I have query parsing errors. Example:

Query (1, 545) The following syntax error occurred during parsing: Invalid token, Line 1, Offset 545, ]. Technical Details: RootActivityId: 3e1686da-7d12-4c05-ad43-05d14496f060 Date (UTC): 2/11/2021 9:48:44 AM

I have some screenshots attached showing how I get the error.

  1. With one filter, use it, all works well;
  2. Add second filter;
  3. When I try to use the second filter added, I have this error.

Thanks

Attachments:
1.jpg
2.jpg
3 error.jpg

1 answer

Public
Milena Pechura Milena Pechura Flexmonster February 12, 2021

Hi, Miguel,
 
Thank you for describing the component behavior in detail and for providing the screenshots.
 
We would like to kindly inform you that our team has not managed to reproduce the issue on our end.
Could you please provide us with access to the Power BI XMLA endpoint? Connecting to the endpoint from our side will greatly help us to investigate the question further and prepare the most suitable solution for your case.
Any sensitive information can be sent to us via email.
 
Looking forward to hearing from you.
 
Best regards,
Milena

Please login or Register to Submit Answer