Download Free Trial

Export to PDF and Export to Image not working – html2canvas is not defined

Using Flexmonster together with SAPUI5 framework has been working fine but for the export to pdf and export to image actions I’ve been getting an error ‘html2canvas is not defined’.
I was able to build an example where it fails like it fails on my application, here is the link:
I hope it helps!
Thanks in advance
Vinicius Cruz Ribeiro

4 answers

Dmytro Zvazhii Flexmonster January 9, 2018

Hello Vinicius,
Thank you for your question. We investigated the issue and found that there is a conflict between html2canvas library and UI5. Therefore we prepared a workaround for this case – As you can see the html2canvas library is included before sap-ui-bootstrap. Please note that you can refer either to the remote html2library or to the lib/html2canvas.min.js located in the flexmonster folder.
Let us know if it solves the case.

Vinicius Cruz ribeiro January 9, 2018

 Hello Dmytro!
Thanks for your help and quick answer. The fix you suggested worked fine for the Export to Image, but now I’m getting error from Export to PDF, on JSFiddle both are working fine yet in my application environment when I choose to export to pdf while having column chart, it throws an error, when I choose a bar chart I it works and downloads the pdf. Unfortunately I could not replicate it on JSFiddle.
I’m attaching a printscreen of the google chrome’s console, I hope it helps!
Thanks in advance,
Vinicius cruz Ribeiro

Tanya Gryshko Flexmonster January 10, 2018

Hello, Vinicius,
Thanks for the feedback!
We are glad to hear that export to the image is working fine for you.
Our team tested Flexmonster together with SAPUI5 framework locally and export to PDF works as expected.
Please check that you are using the latest version of Flexmonster by clicking on the grid and pressing Ctrl+alt+i. If your version is lower than 2.411, we suggest updating.
Also, could you please share with us the printscreen of the error you are getting?

Vinicius Cruz ribeiro January 10, 2018

Hello Tanya,
I had the 2.406 version and updating solved this second problem!
Thank you very much!

Please login or Register to Submit Answer