Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

Flexmoster data server (https problems)

Answered
massimo besozzi asked on October 20, 2020

Hi ,
I have installed Flexmonster data server in a windows machine.
If i test connection with browser on localhost all it’s OK.If I connect from remote host (by name or IP address) i receive this error :”ERR_HTTP2_INADEQUATE_TRANSPORT_SECURITY”.I’m using https connection with a self signed cert.
 
What I’m wrong???
 
 

{
"DataSources": [
{
"Type": "database",
"DatabaseType": "mssql",
"ConnectionString": "Server=$databaseip\\$instanceName;Uid=XXXXX;Pwd=XXXXX;Database=$dbname",
"Indexes": {
"dp_4": {
"Query": "select * from [dbo].[table] "
}
}
}
],
"Security": {
"Authorization": {
"Enabled": true
},
"CORS": {
"AllowOrigin": "https://$apllicationCallerHost"
},
"HSTS": {
"MaxAge": 31536000,
"IncludeSubDomains": true
},
"Headers": {
"Content-Security-Policy": "default-src 'self'",
"X-Content-Type-Options": "nosniff",
"X-Frame-Options": "SAMEORIGIN",
"X-XSS-Protection": "1; mode=block"
}
},
"DataStorageOptions": {
"DataRefreshTime": 60,
"CacheSizeLimit": 15000
},
"Port": "443"
,
"HTTPS": {
"Enabled": true,
"Certificate": {
"Subject": "$certsubject",
"Store": "My",
"Location": "LocalMachine",
"AllowInvalid": true
}
}
}

2 answers

Public
Mykhailo Halaida Mykhailo Halaida Flexmonster October 20, 2020

Hi Massimo,
 
Thank you for posting your question.
 
We’ve experienced similar behavior before – seems like it might either be caused by particular certificate configurations or be related to specific .NET versions.
 
Nevertheless, it can easily be omitted by specifying the safer Http1 as the value of the Protocols configuration for the Data Server:
 

"HTTPS": {
"Enabled": true,
"Protocols": "Http1",
"Certificate": {
"Path": "C:/***.pfx"
}
}

 
Please let us know if this helps.
 
Regards,
Mykhailo

Public
massimo besozzi October 20, 2020

Great it works!!!!!!!
Thanks a lot.I’m waiting the response for linux version (another thread)
Bye.

Please login or Register to Submit Answer