Getting Error – Response to preflight request doesn't pass access control check:

 Hi there,
I have downloaded pivot-accelerator-dll-master fro git hub and setup the data source as my server and try to run the solution and browse simple cube data. I am getting following error.
Response to preflight request doesn’t pass access control check: No ‘Access-COntrol-Allow-Origin’ header is present on the requested resource… therefore not allowed access. The response had HTTP status code 404.
For refference i have attached the screenshot of the console.
Can you help me to resolve the issue

Attachments:
screenshot.png

5 answers

Public
Dmytro Zvazhii Flexmonster February 26, 2018

Hello Abhijeet,
Thank you for your question. It seems that you need to enable CORS on your accelerator server. Please have a look at the following article – https://enable-cors.org/server.html.

Let us know if the information above was helpful for you.
Regards,
Dmytro

Public
Abhijeet Patil February 26, 2018

I have applied the same cors filter but, I am not able to solve the issue
Please see the attached screenshot
 

Attachments:
code.png

Public
Dmytro Zvazhii Flexmonster February 27, 2018

Hello Abhijeet,
Thank you for your feedback. Could you please check the URL you are connecting to? Please try accessing it with your browser – http://localhost:81/api/accelerator. It should respond with the same page as here – http://olap.flexmonster.com:8085/FlexmonsterProxy.
Please let us know if the information above was helpful for you.
Regards,
Dmytro

Public
Abhijeet Patil February 27, 2018

Hello Dmytro,

Thank you so much for your help.

I tried given url it did not work correctly. We are having important delivery tomorrow, we are still facing CORS from last 3 days. Can you please help us to resolve this CORS issue..

Please guide us what we are missing by looking at the code, the solution is copy of git project

For your refference I have attached the project where we are facing the CORS issue. data source is set through the web.config app setting key FlexmonsterDataSource

Thanks in advance!

– Abhijeet Patil

Public
Tanya Gryshko Flexmonster March 1, 2018

Hello, Abhijeet,
Thank for the updates.
We have checked your project. Everything works as expected if we connect to our cube (https://olap.flexmonster.com/olap/msmdpump.dll). This means that the problem is with your msmdpump.dll settings because link http://10.7.4.70/OLAP/msmdpump.dll does not work.
We suggest configuring msmdpump.dll correctly with the help of the detailed guide from Microsoft
Please note, if your cube is located on the same local network (not on another server), you can connect without using msmdpump.dll and providing credentials. The only requirement is that your current Windows user should have access permissions for database and cube.
Let me know whether you have managed to resolve the issue.
Regards,
Tanya

Please login or Register to Submit Answer