Get Free Trial
Get Free Trial

High memory consumption in the new MSAS version

Answered
Rodrigo fraga asked on July 8, 2019

Hello,
After the Flexmonster update of the MSAS version, we faced a very large consumption of memory that came to lock our server.
We have the cache memory limit setting, it seems that you are not respecting this. There was no such problem in the previous version.
Do you have any tips on what we can do?

1 answer

Public
Dmytro Zvazhii Flexmonster July 9, 2019

Hello Rodrigo,
Thank you for writing to us.
We have carefully checked Flexmonster Accelerator and such behavior is not reproducible on our side.
The tests were made on the latest version which is 2.7.9 for now.
 
The "CACHE_MEMORY_LIMIT" property is respected.
Please note, that when you are setting 0 cache memory limit it is meant as unlimited cache space.
When you set some other number the cache space will be limited. If the number of members exceeds the allocated space the accelerator will run cache cleaning operation. You can see appropriate notes in the log file.
 
As an alternative approach, you can try disabling the cache option. Just set "CACHE_ENABLED"= false to disable cache option.
 
Also, we would like to mention that there were no updates added recently that could effect Flexmonster Accelerator memory management. Still, please make sure that you are using the latest version of the component.
 
Let us know if the information helped to resolve the case.
Regards,
Dmytro

Please login or Register to Submit Answer