Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

how to hide icon to open fieldlist

Mauricio Hernandez asked on February 20, 2019

How to hide the icon to open the listfields, is indicated in red in the attached image.


4 answers

Tanya Gryshko Flexmonster February 20, 2019

Hello, Mauricio,
Thank you for writing to us.
We would like to inform you that it is possible via configuratorButton: false option. More details can be found in our docs:
Please let me know in case of other questions.

Mauricio Hernandez February 20, 2019

Thanks Tanya for your answer; this is my code, but don’t resolved my ask:
var pivot = $(“#pivotContainer”).flexmonster({
global: {
localization: “/webapi/scripts/flexmonster/es.txt”
componentFolder: “/webapi/Content/js/Flexmonster/”,
height: “100%”,
beforetoolbarcreated: customizeToolbar,
report: {

dataSource: {
options: {
configuratorButton: false,
viewType: “grid”,
grid: {
showReportFiltersArea: false
ready: function () {



licenseKey: “XXXX-XG174T-44444-6O0K50-YYYYYY-6B624M-555555-092J31-BBBBBB-31”
can you tell me if I’m applying it wrong, regards.

Ian Sadovy Flexmonster February 21, 2019

Hello Mauricio,
Thank you for the details.
Please note, that flexmonster.load() applies the new configuration and report Object is overridden in that case.
So, you can either add global.options.configuratorButton: false or include that option in the /webapi/GenerarJsonAnalisis/1514281/239 config.
Also, you can entirely hide this button using CSS (

#fm-pivot-view .fm-fields-view-wrap #fm-btn-open-fields {
display: none;

Hope it helps.

Mauricio Hernandez February 21, 2019

Thanks, it’s perfect!

Please login or Register to Submit Answer