Get Free Trial

how to localize captions

Paul Schlichter asked on July 28, 2016

This is from an earlier answer to
Caption of aggregated values, hide columns
The only way to configure the component like you want, is to set a new localization file with the empty “grandTotalCaption” and “totalCaption” attributes, here is an example of such localization file If you use .xml report it will look like this
<param name=”localSettingsUrl”><![CDATA[]]></param>
I have tried to do this with the following embedded pivot. It is not working. Any suggestion or pointers would be appreciated
 var pivot1=flexmonster.embedPivotComponent(“flexmonsteradvanced/”, “pivotContainer1″,”99%”, “580”, {configUrl : “configmysql.xml”,localSettingsUrl: “configlocalnoagg.xml”},true);

2 answers

Dmytro Zvazhii Dmytro Zvazhii Flexmonster July 29, 2016

Hi Paul,

Please try to define localSettingsUrl in the configmysql.XML file. In the current version you can use XML file OR json object to configure report but not both of them at the same time. In the next version we will add support for mixed configurations but now you have to choose only one of them.

Tanya Gryshko Tanya Gryshko Flexmonster December 5, 2016

Hello Paul and all Flexmonster users,
In version 2.3 localization is set via JSON. localSettingsUrl parameter is replaced with localization. Read more about the changes: Localizing component. Check the updated sample:

Please login or Register to Submit Answer