Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

IE 11 error

Answered
Abhilash asked on December 9, 2020

Hi,
I’m seeing below error in IE11 the Angular app doesn’t even load. when i click the error it pointed me towards a function with in flexmonster pivot table. Can you help resolve this? let me know if you need any other details. Appreciate your help
Angular/cli – 6.0.3
ng-flexmonster – 2.8.19
 
 
 
 

Attachments:
error1.PNG
error2.PNG

8 answers

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 10, 2020

Hello,
 
Thank you for reporting the issue.
 
We want to explain that our wrapper for Angular uses the ES6 version of Flexmonster.
Being incompatible with IE, ES6 standard leads to the error.
We suggest modifying our wrapper in the way it uses ES5 instead of the default ES6 version.
The wrapper’s source code can be found on our GitHub.
The following line of code is responsible for importing Flexmonster. Please replace the path with the following string: flexmonster/flexmonster.es5.full.
 
Also, please note that this wrapper should be embedded in your project manually instead of installing it through npm.
 
Please let us know if it works for you.
 
Best regards,
Illia

Public
Abhilash December 10, 2020

Hi,
I’m sorry I didn’t quite understand what should be changed. Do you want me to go ahead and change some file in node_modules folder? this is what i see in node_modules/ng-flexmonster

Attachments:
1.PNG

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 11, 2020

Hello,
 
Thank you for giving us some time.
 
Currently, the Angular wrapper for Flexmonster is installed as an npm module in your project. In order to make it use the ES5 version of the component, it needs to be embedded in your project manually instead of using it as an npm module.
 
It means this wrapper can be removed from your npm dependencies.
Instead, download the wrapper’s source code from our GitHub.
Next, modify the import statement in the flexmonster.component.ts file as shown below:

import { Component, ElementRef, Input, Output, EventEmitter } from '@angular/core';
import * as Flexmonster from 'flexmonster/flexmonster.es5.full';

@Component({
  selector: 'fm-pivot',
  template: '<div><div class="fm-ng-wrapper"></div></div>'
})

...

 
We have prepared a sample Angular project to demonstrate this approach. It can be found in attachments.
In this example, flexmonter.component.ts and flexmosnter.module.ts are embedded directly into the src/app folder of the application.
 
Please let us know if it works for you.
Our team is looking forward to hearing your feedback.
 
Best regards,
Illia

Public
Abhilash December 11, 2020

Thanks I’ll try this and let you know, So what happens if i want to update flexmonster version in the future?

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 11, 2020

Hello,
 
Thank you for your feedback.
 
Our team would like to notice that in this case, the wrapper needs to be updated manually. Yet, we want to notice that the Angular wrapper does not receive significant updates every minor release. Further versions of the component are likely to be compatible with older versions of the wrapper.
 
Even so, we understand your concerns on this point. Our team agrees that the possibility to use our npm package with the ES5 version of the component sounds reasonable.
Therefore we have added this request to our backlog.
 
We will notify you in case something is changed on this point.
 
Feel free to reach out in case any further questions arise.
 
Best regards,
Illia

Public
Abhilash December 13, 2020

Thanks this worked fine for me. Will I lose any flexmonster ES6 features by doing this that I have to look for?

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 14, 2020

Hello,
 
Thank you for your feedback.
 
We want to notice that the ECMAScript standard does not affect the functionality of the component.
The same list of features is available both for ES5 and ES6 Flexmonster’s versions.
 
Feel free to contact us in case any further questions arise.
 
Regards,
Illia

Public
Abhilash December 15, 2020

Thanks for the quick fix. Appreciate it

Please login or Register to Submit Answer