🍉 Meet Flexmonster Pivot Table & Charts 2.9.Check out all the hot features!
Get Free Trial

In flat mode, auto-width doesn't work to extend a very wide column to show everything

Serban Vasile asked on August 26, 2019

See attachment, in flat mode, for a column that is wide enough, the max column width is set to 480 px, and then the content of the div is trimmed with the text-overflow option css option(elipsis). That is fine, as long as a double-click on the column header would allow the content to extend to show everything, or at least when one hovers on top of the cell, a little pop-up would show the full content.
We entered debug mode and saw the content is there in the div. It’s just masked by the max-width option of the div. 
Please fix this. It might sound like it’s not much, but it’s very important.
PS. We know “export” shows the full the content, but it’s cumbersome and it defeats the purpose of using FlexMonster to use another tool to see one cell’s extra width field.


2 answers

Vera Didenko Vera Didenko Flexmonster August 27, 2019

Hello, Serban,
Thank you for writing to us.
It’s possible to override maximum column/row width using CSS classes .fm-grid-column/.fm-grid-row:

#fm-pivot-view .fm-grid-column {
max-width: 1000px;
#fm-pivot-view .fm-grid-row {
max-height: 300px;

 Here is a JSFiddle example for illustration.
You can also use the customizeCell() API call to add pop-ups on hover.
Please refer to the following threads for reference:
1) https://www.flexmonster.com/question/how-to-have-a-header-multiline/
2) https://www.flexmonster.com/question/tooltips-on-header-of-the-kpis/
Let us know if everything works fine for you.
Best Regards,

Serban Vasile August 28, 2019

Thanks a bunch, this will do it.

Please login or Register to Submit Answer