Get Free Trial
Get Free Trial

Kibana Plugin – index selection not working

Answered
Martin asked on December 17, 2019

Hello,
i’ve installed the Flexmonster Pivot Plugin for Kibana following your guide at:
https://github.com/flexmonster/pivot-kibana/
 
The Flexmonster Pivort plugin is available, trying to select an index, it hangs at “loading options” and nothing more happens. What did I wrong?

The Dev Tools Console  looks good, no JS errors available.

My environment:
OS:Centos7
elasticsearch 7.3.2
kibana 7.3.2

Thanks for help in advance,
Best regards,
Martin
 
 

7 answers

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 18, 2019

Hello, Martin,
 
Thank you for reaching out to us.
 
Our team would like to kindly recommend checking out whether CORS for Kibana is enabled. It is achievable through opening kibana.yml and adding the following configuration: 

elasticsearch.hosts: ["http://localhost:9200"]
server.cors: true
server.cors.origin: ['*']

 
We hope it works for you.
 
Kind regards,
Illia

Public
Martin December 19, 2019

Hello Illia,
 
Thanks for help. I’m running my elasticsearch and kibana in a headless VM, so I had to activate 
the production mode settings to get it work.
 
kibana.yml
elasticsearch.hosts: [“http://192.168.102.106:9200”]
server.cors: true
server.cors.origin: [‘*’]

Is there a way to get the pivot plugin working with the production mode settings (and basic authentication)?

I’ve also installed elasticsearch and kibana in an other VM with Desktop; here the pivot tables work, using the browser from the Desktop in the VM.
My goal would be, to get it running in an headless VM, like for production.

Best regards,
Martin
 

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 19, 2019

Hello, Martin,
 
Thank you for your feedback.
 
Our team would like to kindly inform you that the pivot plugin is developed for production mode.
 
The connection object from Kibana is used to communicate with Elasticsearch.
 
Basic authentication (or any other) can be set up on your side. There are no requirements for any specific security settings in the plugin. If a browser can get data from the server, the component will visualize them.
 
Also we would like to kindly draw your attention to the fact that CORS has to be enabled for Elasticsearch as well.
It can be implemented using the following approach:
Open elasticsearch.yml and add the following configuration:

http.cors.enabled : true
http.cors.allow-origin : "*"
http.cors.allow-credentials: true
http.cors.allow-methods : OPTIONS,HEAD,GET,POST,PUT,DELETE
http.cors.allow-headers : kbn-version,Origin,X-Requested-With,Content-Type,Accept,Engaged-Auth-Token,Content-Length,Authorization

 
Best regards,
Illia

Public
Martin December 20, 2019

Hello Illia,

I already had the http.cors configuration in elasticsearch.yml.
i can’t select an index in the pivot plugin when have the production settings activated.

Here my active configuration:
kibana.yml
server.port: 5601
server.host: “192.168.102.106”
server.name: “elk732”
elasticsearch.hosts: [“http://192.168.102.106:9200”]
server.cors: true
server.cors.origin: [‘*’]
elasticsearch.username: “kibana”
elasticsearch.password: “12345678980”

 
elasticsearch.yml
cluster.name: elk
node.name: elk732
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
bootstrap.memory_lock: true
network.host: 192.168.102.106
http.port: 9200
discovery.seed_hosts: [“elk732”]
cluster.initial_master_nodes: [“elk732”]
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: elastic-certificates.p12
http.cors.enabled : true
http.cors.allow-origin : “*”
http.cors.allow-credentials: true
http.cors.allow-methods : OPTIONS,HEAD,GET,POST,PUT,DELETE
http.cors.allow-headers : kbn-version,Origin,X-Requested-With,Content-Type,Accept,Engaged-Auth-Token,Content-Length,Authorization
 
everyting else seems to work. Any ideas?
Best regards,
Martin

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster December 24, 2019

Hello, Martin,
 
Thank you for your feedback.
 
We would like to recommend checking whether a connection to Kibana, that is received by Flexmonster has enough permission in order to access the specific index.
 
Regards,
Illia

Public
Martin January 10, 2020

Hello Illia,
 
I’m using in my Lab environment the “elasic” user with the role “superuser”; this should have enough permissions.
 
Attached is the output from the Chrome’s Dev console. Where could I set the “unsafe-inline” keyword to enable inline execution?
Thanks.
 
Best Regards,
Martin
 
 

Attachments:
Flexmonster_error.JPG

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster January 13, 2020

Hello, Martin,

Thank you for your feedback.

It seems that the script that used in order to access indexes is rejected by the Content Security Policy (CSP). That causes the error shown on the provided screenshot.
 
We would like to kindly recommend trying to disable the CSP and compare the achieved results. In case the problem is resolved, our team suggests adjusting CSP in the way the conflict with the script above is removed.
 
Regards,
Illia

Please login or Register to Submit Answer