Menu
Download Free Trial

Loading hierarchies step gives error: Request signature is not trusted or invalid.

Hi,
I am trying to setup Flexmonster. But I take error on  “Loading hierarchies” step. I can reach the cube via Excel using msmdpump.dll
Can you help me?
Log details are below:
 
2017-05-07 09:37:59.0628 | TRACE | Starting server…
2017-05-07 09:37:59.0628 | TRACE | Starting server – OK
2017-05-07 09:37:59.0628 | TRACE | Server is running at http://localhost:50005/
2017-05-07 09:38:05.7281 | TRACE | Handshaking…
2017-05-07 09:38:05.8261 | TRACE | Loading dimensions…
2017-05-07 09:38:05.8261 | TRACE | Connection string: Data Source=localhost;UID=flexmonster;Password=*** ;Catalog=OlapTest;
2017-05-07 09:38:05.8371 | TRACE | Connection string: Data Source=localhost;UID=flexmonster;Password=***;Catalog=OlapTest;
2017-05-07 09:38:05.8501 | TRACE | CACHE: Add – Flexmonster.Accelerator.Models.DiscoverArgs
2017-05-07 09:38:05.8501 | TRACE | CACHE: Memory – 6160408 / 0
2017-05-07 09:38:05.8501 | TRACE | CACHE: Items in cache: 1
2017-05-07 09:38:05.8501 | TRACE | Dimensions: 3 loaded [14 ms]
2017-05-07 09:38:05.9241 | TRACE | Loading hierarchies…
2017-05-07 09:38:05.9241 | WARN | Request signature is not trusted or invalid.
Source Code:
var pivot = $(“#pivotContainer”).flexmonster({
                toolbar: true,
                report: {
                    dataSource: {
                        dataSourceType: “microsoft analysis services”,

                        /* URL to the Data Speed Accelerator */
                        proxyUrl: “http://localhost:50005”,
                        

                        /* Catalog name */
                        catalog: “OlapTest”,

                        /* Cube name */
                        cube: “MyCube”,
                        

                        /* Flag to use Data Speed Accelerator instead of XMLA protocol */
                        binary: true
                    }                
                },
                licenseKey: “********”

            });
 

5 answers

Public
Tanya Gryshko Flexmonster May 8, 2017

Hello Bülent,
Thank you for the interest in our component. Could you please provide us the access to your msmdpump.dll or make the backup of the cube? This would greatly help us to reproduce the problem on our side.
Regards,
Tanya

Public
Ian Sadovy Flexmonster May 9, 2017

Hello Bülent,
Thank you for the provided access.
Seems that Accelerator is currently stopped on your side.
Still, we have started Accelerator on our side with a connection to your cube via msmdpump:
CONNECTION_STRING=Data Source=XXX/olap/msmdpump.dll
and it seems working as expected with no errors.
Could you please restart Accelerator on your side to check it again?

 
Thanks,
Ian

Public
Dmytro Zvazhii Flexmonster May 11, 2017

Hello Bülent,
Thank you for your quick response. It seems that the port 50005 is closed on your environment. Could you please check it and open port 50005 in the firewall? We could not continue our investigation since it is closed for outside world.
Waiting for your feedback.
Best regards,
Dmytro.

Public
Dmytro Zvazhii Flexmonster May 11, 2017

Hi Bülent,
Thank you for helping us to reproduce the issue. We have reproduced the problem on our side and will make the necessary update in the version 2.317 ETA Jun06. Could you please leave the port open until that time since we need to test our solution? For now, we recommend you using the xmla connection.
Best regards,
Dmytro.

Public
Ian Sadovy Flexmonster May 31, 2017

Hello Bülent,
 
Thank you for giving us some time.
We have prepared an update for Accelerator that may fix the issue with “Request signature is not trusted or invalid” error.
It is available for download from here – https://s3.amazonaws.com/flexmonster/bulent-sari/FLEXMONSTER-2017-BULENT-SARI-MAY31.zip
Please verify and let us know if it resolves the issue on your side.
 
Regards,
Ian

Please login or Register to Submit Answer