Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

Show the Field List in their CSV data order instead of an alphabet sort

Answered
Shripal Dalal asked on July 16, 2020

Dear All,
We just upgraded from your very old Flash version to the latest HTML5 version. We had an excellent feature in the Flash version, that when the grid was in Flat Form, the field list would be exactly the way it would be in the CSV file.
The problem is now the field list in flat form comes alphabetically sorted. The problem is if my CSV has 75 columns and I take it in flat form, it would be a nightmare for me to sort the entire report. Can I disable the field list formatting and just do the select all, then all my problems would be solved with this.
Thanks.
Regards,
Shripal Dalal,
ORIOR IT Consulting Pvt Ltd.

2 answers

Public
Milena Pechura Milena Pechura Flexmonster July 17, 2020

Hello, Shripal,
 
Thank you for writing to us.
 
Please note that when there is no slice defined in the report, the Field List in the flat form comes unsorted with all fields selected.
We have prepared an example for illustration: https://jsfiddle.net/flexmonster/1ue70xom/.
 
Please contact us in case it helps or if any further questions arise.
 
Kind regards,
Milena

Public
Shripal Dalal July 17, 2020

Dear Milena,
It works! My mistake was that I did not specify flat table from scratch and it started in compact mode, which sorted all the fields alphabetically!
Thank you for the prompt support! 🙂

Please login or Register to Submit Answer