Unable to use after enabling Kibana user management

Answered
Kai asked on July 11, 2019

I installed flexmonster in Kibana to use the pivot table function. Everything works fine until I enable the user management, after that each time I click the Flexmonster icon, the page just go back to the login page, the error message is “Your session has timed out. Please log in again.”. Does anyone know what’s going on? Thanks. 

4 answers

Public
Vera Didenko Flexmonster July 12, 2019

Hello, Kai,
 
Thank you for writing to us.
 
We would like to explain that Flexmonster does not interfere with the user management process. 
 
Our team kindly suggests checking your kibana.yml file and adjusting the sessionTimeout parameter.
Here is a link for reference: https://www.elastic.co/guide/en/kibana/current/using-kibana-with-security.html

Please let us know if this helps.
 
Best Regards,
Vera

Public
Kai July 15, 2019

Hi, Vera
Thanks for your reply. I’ve tried all the parameters related with Timeout in kibana.yml but still not working.
The error message is:
http://localhost:5601/login?next=%2Fapp%2Fflexmonster_pivot&msg=SESSION_EXPIRED#?_g=()
Since Flexmonster works fine before I enable user management, I think there’s something related with it. 
After I clicked the Flexmonster icon, several windows flashed and then I went back to the login UI with session timeout message. 
I want to attach my yml files but seems it’s not allowed. I’ll just paste the content here.
Elasticsearch.yml:
http.cors.enabled : true
http.cors.allow-origin : “*”
http.cors.allow-credentials: true
http.cors.allow-methods : OPTIONS, HEAD, GET, POST, PUT, DELETE
http.cors.allow-headers : kbn-version, Origin, X-Requested-With, Content-Type, Accept, Engaged-Auth-Token, Content-Length, Authorization
xpack.security.enabled: true
discovery.type: single-node
 
Kibana.yml:
elasticsearch.hosts: [“http://localhost:9200”]
server.cors: true
server.cors.origin: [‘*’]
kibana.index: “.kibana”
elasticsearch.username: “kibana”
elasticsearch.password: “kibana”
elasticsearch.pingTimeout: 600000
elasticsearch.requestTimeout: 600000
elasticsearch.shardTimeout: 600000
elasticsearch.startupTimeout: 600000
xpack.security.sessionTimeout: 600000

Public
Tanya Gryshko Flexmonster July 16, 2019

Hello, Kai,

Thank you for your answer.

As we see from your kibana.yml, not all X-Pack parameters are configured. We kindly suggesting checking once more all steps of this tutorial: https://www.elastic.co/guide/en/kibana/current/using-kibana-with-security.html. Also, please don’t forget to restart Kibana. Additional info about X-Pack parameters for Kibana can be found here: https://www.elastic.co/guide/en/kibana/current/security-settings-kb.html.

Please let us know if it helps.

Regards,
Tanya

Public
Ian Sadovy Flexmonster August 8, 2019

Hello Kai,
 
We have investigated the issue with X-Pack and SESSION_EXPIRED and fixed the problem.
Please try the new release https://github.com/flexmonster/pivot-kibana/releases/tag/v1.17
 
Also, please note, that sometimes Kibana requires the following sequence to update plugin correctly:

  1. Uninstall old plugin
  2. Start/stop Kibana
  3. Install new plugin
  4. Start Kibana

Hope it helps.
 
Regards,
Ian

Please login or Register to Submit Answer