Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

Attribute "simplifyFieldListFolders" is not working

Answered
Miguel Duarte asked on February 3, 2021

Hello,
While using a Power BI Premium dataset as data source (which should count as SSAS or Azure Analysis Services data source), I find this field not to be working properly.
I want all the folders to show up on the Field List, including the folder containing only one attribute (instead of having them in the root folder). It is important because of the naming convention we use.
When I add it to my Flexmonster instance, it does not make any difference. This is the code I am using:

let reportString = {
"dataSource": {
"type": "microsoft analysis services",
"proxyUrl": "xxxxx",
"catalog": "xxxxx",
"cube": "Model",
"binary": true,
},
"slice": {
"expands": {
"expandAll": true
},
"drills": {
"drillAll": true
}
},
options: {
"simplifyFieldListFolders": false,
"configuratorActive": true,
"useOlapFormatting": true
}
}

I attached a screenshot showing the issue. You can see there 3 folders and 5 attributes not belonging to any folder. Each of these 5 attributes should be in a folder.

2 answers

Public
Vera Didenko Vera Didenko Flexmonster February 4, 2021

Hello, Miguel,
 
Thank you for writing to us. 
 
We would like to explain that recently our team has fixed a similar issue. 
With this in mind, we kindly suggest updating Flexmonster and updating Flexmonster Accelerator to the latest version.
 
Please let us know if updating to the latest version helps to resolve the issue.
Looking forward to your response.
 
Kind regards,
Vera

Public
Miguel Duarte February 4, 2021

Hi Vera,
Indeed, after updating react-flexmonster I can confirm that the issue is now gone.
Best,
Miguel

Please login or Register to Submit Answer