Dear visitor, despite all the challenges, our team continues operating at full speed.

We are ready to help with any questions you may have. Please fill out this quick form and we'll get back to you.

Fill the form
Get Free Trial

Bug: Deselecting field changes from measure

Resolved
Patrick Berens asked on June 16, 2020

Hi support,
 
I have a table with 4 fields, two of them numbers. When I click on fields, I see all 4 fields and the two measures have the SUM symbol next to them. If I deselect one, then close and reopen, it no longer shows the SUM symbol.

Reproduce:
1. Create Report with 4 fields, two of which are strings, two are numbers.
2. Go to Flat Grid View. Click on Fields, notice both fields are numbers in selector (They both show SUM symbol).
3. Deselect one number field and one string field so only one string and number fields selected.
4a. Close Fields Modal.
4b. (optional) Click Charts then Pie Chart. Notice is creates successfully.

5. Reopen Fields modal.
6. Notice that the deselected field no longer has SUM symbol.
7. Deselect the currently selected number field. Select the old deselected number field. (i.e. swap the selected number fields).
8. Notice that the SUM symbol still isn’t shown. Close the modal. Open a pie chart again, it will error saying: “No measures to display. Add at least one measure in the Field List.” However, there is a measure selected.
 
Expected Behavior:
When reopening the field selector modal, it should show “SUM” selector in Fields selector modal next to all numbers. Also, you should then be able to select Pie Chart and it should load correctly, just as it does when a number is first selected on table load.
 
Attached two photos showing the two states. “fields_1.png” shows initial state of fields. “fields_2.png” shows number field without SUM when reopen.

Attachments:
fields_1.png
fields_2.png

5 answers

Public
Mykhailo Halaida Mykhailo Halaida Flexmonster June 17, 2020

Hi Patrick,
 
Thank you for writing to us.
 
We’ve managed to reproduce the reported behavior on our side – we are going to investigate this further and return to you with a fix ETA Jul 13th.
 
Please let us know if this works for you.
 
Regards,
Mykhailo

Public
Patrick Berens June 17, 2020

Works great, thanks!
Patrick

Public
Mykhailo Halaida Mykhailo Halaida Flexmonster July 14, 2020

Hi Patrick,
 
We are pleased to inform you that the issue with displaying and selecting measures in the flat mode was fixed.
 
This is available in the 2.8.11 version of Flexmonster: https://www.flexmonster.com/release-notes/
 
You are welcome to update the component. Here is our updating to the latest version guide for assistance: https://www.flexmonster.com/doc/updating-to-the-latest-version/
 
Please contact us in case any questions arise.
 
Best regards,
Mykhailo

Public
Mykhailo Halaida Mykhailo Halaida Flexmonster July 22, 2020

Hi Patrick,
 
Hope you’re doing well.
 
We were wondering if you’ve had a chance to check out the recent fix we’ve mentioned in our previous response. Has the issue been fixed on your side? 
 
We would be happy to hear your feedback.
 
Regards,
Mykhailo

Public
Patrick Berens July 25, 2020

Thanks, upgrading seems to have done the trick!
Patrick

Please login or Register to Submit Answer