Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

[BUG] Flat table view does not load values for fields in report filters

Re-Open
eze@wejugo.com asked on November 9, 2020

Hello again, we noticed a bug when switching a report from classic/compact mode to flat view mode.
An example can be seen here: https://jsfiddle.net/ezk84/5c367bv4/7/
If there is a report filter set on the report (whether the filter is set to a value or not doesn’t matter) the flat view does not contain any values for the fields that are in the filter. Sometimes some sporadic values are shown (though I wasn’t able to replicate this against the fm-product-sales data).

If one de-selects and re-selects the columns from the flat table view, all the wanted values show. 
 
Cheers,
Ezequiel

5 answers

Public
Milena Pechura Milena Pechura Flexmonster November 10, 2020

Hello, Ezequiel,
 
Thank you for reporting the problem.
 
We would like to inform you that we are currently working on a fix, as one of our clients also reported such issue.
 
The fix is going to be provided with a minor update ETA Nov 16.
Our team will notify you as soon as the version with a fix is available to download.
 
Feel free to reach out in case any other questions arise.
 
Best regards,
Milena

Public
Milena Pechura Milena Pechura Flexmonster November 17, 2020

Hi, Ezequiel,
 
We are glad to announce that the issue with using reportFilters in flat form for custom API data source was fixed.
This is available in the 2.8.20 version of Flexmonster: https://www.flexmonster.com/release-notes/.
 
You are welcome to update the component.
Here is our updating to the latest version guide for assistance: https://www.flexmonster.com/doc/updating-to-the-latest-version/.
 
Feel free to write to us in case of questions.
 
Best regards,
Milena

Public
eze@wejugo.com November 18, 2020

Thank you, will give that a go 🙂

Public
Milena Pechura Milena Pechura Flexmonster 2 days ago

Hello, Ezequiel,
 
Our team is wondering whether the recent fix helped.
Please let us know if everything works fine.
 
We are looking forward to hearing from you.
 
Kind regards,
Milena

Public
eze@wejugo.com 1 day ago

Hello, have tested that now and it works! Thank you for your support on all these issues.
 
Cheers,
Eze

Please login or Register to Submit Answer