Get Free Trial

cell symbol

Answered
dror asked on November 21, 2021

hello there i try to  make formats on the json file to create symbol for cell but it does not show it this is my json file please help me to fix it i want to make a percent symbol. the format is Percent Traded Volume
thanks 

{
    “dataSource”: {
        “dataSourceType”: “csv”,
        “filename”: “”
    },
    “formats”: [
        {
            “name”: “Percent Traded Volume”,
            “thousandsSeparator”: “,”,
            “decimalSeparator”: “.”,
            “decimalPlaces”: 3,
            “maxSymbols”: 20,
            “currencySymbol”: “%”,
            “positiveCurrencyFormat”: “1%”,
            “currencySymbolAlign”: “left”,
            “textAlign”: “left”,
            “isPercent”:true
        }
    ],
    “slice”: {
        “rows”: [
            {
                “uniqueName”: “execution_type_name”,
                “sort”: “asc”
            }
        ],
        “columns”: [
            {
                “uniqueName”: “[Measures]”,
                “sort”: “asc”
            }
        ],
        “measures”: [
            {
                “uniqueName”: “Volume”,
                “caption”: “Sum per type”,
                “active”: true
               
            },
           
            { 
 
                “uniqueName”: “Volume”,
                “aggregation”:”percentofcolumn”,
                “caption”: “Percent Traded Volume”,
                “active”:true
                “format”: “Percent Traded Volume”
            }
        ]
    },

    “options”: {
        “viewType”: “grid”,
        “grid”: {
            “type”: “compact”,
            “title”: “Traded Volume”,
            “showFilter”: true,
            “showHeaders”: true,
            “fitGridlines”: false,
            “showTotals”: true,
            “showGrandTotals”: “on”,
            “showExtraTotalLabels”: false,
            “showHierarchies”: true,
            “showHierarchyCaptions”: true,
            “showReportFiltersArea”: true,
            “pagesFilterLayout”: “horizontal”
        },
        “chart”: {
            “type”: “pie”,
            “title”: “Traded Volume”,
            “showFilter”: true,
            “labelsHierarchy”: “”,
            “multipleMeasures”: false,
            “oneLevel”: false,
            “autoRange”: false,
            “reversedAxes”: false,
            “showLegendButton”: false,
            “showAllLabels”: false,
            “showMeasures”: true,
            “showOneMeasureSelection”: true,
            “showWarning”: true,
            “activeMeasure”: “”
        }
       
    }
   
}

1 answer

Public
Vera Didenko Vera Didenko Flexmonster November 22, 2021

Hello,
 
Thank you for writing to us.
 
We noticed that you are using the percentofcolumn aggregation. For percent aggregations, Flexmonster adds the percent (%) symbol automatically.
Here is a JSFiddle example: https://jsfiddle.net/flexmonster/7txhwu6p/
You can also define a default number formatting rule for all measures. At the same time, you can format the values of certain measures by setting a specific number formatting rule.
 
Please note that for percent aggregations, the percent symbol position isn’t affected by number formatting rules.
If you need to position the percent symbol differently for percent aggregations, a possible solution is to create a calculated value.
Here is an example illustrating this approach: https://jsfiddle.net/flexmonster/3jvm4z1w/.
 
Please let us know if this helps. If any additional questions arise, feel free to reach out.
 
Kind regards,
Vera

Please login or Register to Submit Answer