Get Free Trial

Date type is not working

Djilan asked on January 5, 2021

I have a problem with the date format. I wish all my dates were in the format: yyyy-MM-dd. In my example, a date “Date de début d’exécution du plan” doesn’t want to be in this format.
I don’t understand because for others, it’s work ..
I looked at forums with similar issues but couldn’t find the solution.
Can you help me ?
Thank you

4 answers

Djilan January 6, 2021

I think I found the problem but I still don’t have a solution.
When a date has 01 in the month AND 01 in the day AND that it appears first in the JSON, this does not work. Example: 2020-01-01 or 2018-01-01 …

Mykhailo Halaida Mykhailo Halaida Flexmonster January 8, 2021

Hi Djilan,
Thank you for posting your question.
We’ve managed to reproduce the strange field behavior when the first data entry contains a 01-01 date – our team will take a look at this and provide a fix with our upcoming release on ETA Jan 25th.
In the meantime, we’d suggest configuring the date fields’ type through the Mapping Object on your side:

dataSource: {
mapping: {
"Date1": {
type: "date string"

If you set the field’s type to a specific date type explicitly, the pivot table parses the data correctly.
Also, as a side note, on your date3.png screenshot, we’ve noticed that the Global Object is misconfigured: the licenseKey property should be outside the Global/Report object, while the defaultDateType and the datePattern properties should be specified inside the Options Object.
We hope this helps.
Best regards,

Mykhailo Halaida Mykhailo Halaida Flexmonster January 26, 2021

Hi Djilan,
We are glad to inform you that the issue with parsing date fields was fixed.
This is included in the 2.8.25 version of Flexmonster:
You are welcome to update the component. Here is our updating to the latest version tutorial for guidance:
Please let us know if this helps.
Kind regards,

Djilan January 27, 2021

Thank you !

This question is now closed