Dear visitor, despite all the challenges, our team continues operating at full speed.

We are ready to help with any questions you may have. Please fill out this quick form and we'll get back to you.

Fill the form
Get Free Trial

Error when adding the same measure/value several times in MSAS

Closed
Javier González asked on June 4, 2020

Hello,

I’d like to report an error that occurs when adding the same measure/value several times to the pivot table, at least when the datasource is MSAS.

I’ve managed to reproduce it on one of your jsfiddle, for example: https://jsfiddle.net/flexmonster/7g82cnn3/

  1. Configure the fields as in ValuesError.PNG. As you see, in the values I have “Order Count” two times, one as “No Calculation” and the other as “% of Grand Total of Order Count”. Click on apply.
  2. The “% of Grand Total of Order Count” doesn’t appear on the report. And it has also been removed on the “Values” of the fields configuration modal if you open it up again.

I played a little more with it and sometimes it appears but then no numbers are shown. Also, sometimes, both values on the fields window get changed and both appear as “% of Grand Total of Order Count” although I didn’t change the first one.

Overall, it seems that the behaviour is quite random and inconsistent. I tested this with the latest version available right now (2.8.8).

If it helps, I did not manage to reproduce it on other examples that don’t seem to use MSAS.

Could you check this out, please? We are on the middle of a development which uses this functionality (configuring the same value/measure several times).

Thank you.

Attachments:
ValuesError.PNG

3 answers

Public
Vera Didenko Flexmonster June 4, 2020

Hello, Javier,
 
Thank you for reaching out to us and for providing additional details about the problem.
 
We would like to confirm that this is not the expected behavior. 
Our team will provide the fix for this issue in the minor release version with the ETA 30th of June.
 
Please let us know if you have any additional questions.
 
Kind regards,
Vera

Public
Mykhailo Halaida Mykhailo Halaida Flexmonster July 1, 2020

Hi Javier,
 
We are happy to inform you that the issue when adding measures with different aggregations to slice was fixed.
 
This is included in the 2.8.10 version of Flexmonster. You are welcome to update the component. Here is our updating to the latest version tutorial for guidance.
 
Please let us know if everything works fine for you.
 
Best regards,
Mykhailo

Public
Javier González July 2, 2020

Thanks for the update, Mykhailo.

This question is now closed