Get Free Trial

Export functionality only with first 1K rows

Answered
Morales, Julio César Álvaro asked on August 1, 2022

When I use the Export function on the grid table, it only includes the first 1000 records plus the headers
Flexmonster version used:

“ng-flexmonster”: “^2.9.29”,

 
and here is how I’m calling the function:
 

export() {
    this.pivot.flexmonster.exportTo(‘excel’);
 }
 

Thank your for your help and support

9 answers

Public
Nadia Khodakivska Nadia Khodakivska Flexmonster August 2, 2022

Hello,

Thank you for contacting us.

We suppose that you are trying to export the data from the drill-through. When you open the drill-through pop-up window for "api", "microsoft analysis services", and "elasticsearch" data source types, it displays 1000 rows by default. You can define the maximum number of rows for the drill-through using drillthroughMaxRows property of the Options Object.

Please let us know if it works for you. Feel free to contact us if other questions arise.

Kind regards,
Nadia

Public
Morales, Julio César Álvaro August 2, 2022

Correct in the opened window displays the 1000 rows and also the issue is once we want to export the entire values. I already test the drillthroughMaxRows configuration and the result was the same
 
Thank you

Public
Nadia Khodakivska Nadia Khodakivska Flexmonster August 4, 2022

Hello,

Thank you for the response.

We couldn’t reproduce the described behavior on our side. Kindly check the following JSFiddle illustrating that everything works as expected: https://jsfiddle.net/flexmonster/45zd2n1s/
Also, note that if you have a custom implementation of Custom Data Source API, there’s a limit parameter in the /select request for the drill-through view defined by the drillthroughMaxRows property.

You are welcome to write to us in case further questions arise.

Kind regards,
Nadia

Public
Morales, Julio César Álvaro 4 days ago

Yes correct, I’m using exactly this code:

 report: Flexmonster.Report = {
    localization: {
      grid: {
        blankMember: ”,
        dateInvalidCaption: ”,
      },
    },
    dataSource: {
      type: ‘api’,
      url: environment.flexmonsterDataServerUrl,
      index: ‘EpromiseDB’,
      mapping: {
        DOCK_DATE: {
          type: ‘date string’,
        },
        NEED_DATE: {
          type: ‘date string’,
        },
      },
    },
    options: {
      datePattern: ‘MM/dd/yyyy’,
      defaultDateType: ‘date string’,
      drillThrough: true,
      showAllFieldsDrillThrough: true,
      grid: {
        showHeaders: true,
        drillThroughMaxRows: 3000000
      }
    }

};
 

If you can help me please, because I’m still getting the same 1000 rows, not sure if I have to put something else in the dataserver query or configuration

Public
Nadia Khodakivska Nadia Khodakivska Flexmonster 3 days ago

Hello,

Thank you for the response.

We recommend updating Flexmonster Data Server to the latest version: https://www.flexmonster.com/doc/updating-to-the-latest-version/#update-data-server 

Please let us know if everything works fine.

Kind regards,
Nadia

Public
Morales, Julio César Álvaro 3 days ago

Version: 2.9.31 for Data Server
It’s the new version I’m testing and the drillThroughMaxRows: 3000000 still not working

Public
Nadia Khodakivska Nadia Khodakivska Flexmonster 2 days ago

Hello,

Thank you for the response.

A possible reason for the described behavior may be a misprint when specifying the drillthroughMaxRows property. Our team noticed that the drillthroughMaxRows property is written differently in your message – “drillThroughMaxRows”. In this case, this property will be ignored. We kindly recommend checking the same with drillthroughMaxRows and seeing whether it works.

Looking forward to hearing from you.

Kind regards,
Nadia

Public
Morales, Julio César Álvaro 2 days ago

The Options object shows below interface, when I changed to the above recommendation, it throws me an error, should I do something else? Or it should be under a different part into the Report object?
 
interface Options {
        chart?: {
            activeMeasure?: MeasureObject | MeasureObject[];
            activeTupleIndex?: number;
            autoRange?: boolean;
            labelsHierarchy?: string;
            multipleMeasures?: boolean;
            oneLevel?: boolean;
            showFilter?: boolean;
            showLegend?: boolean;
            showLegendButton?: boolean;
            showMeasures?: boolean;
            showWarning?: boolean;
            title?: string;
            type?: string;
            showDataLabels?: boolean;
            reversedAxes?: boolean;
            showAllLabels?: boolean;
            showOneMeasureSelection?: boolean;
            position?: string;
            pieDataIndex?: string;
            axisShortNumberFormat?: boolean;
        };
        grid?: {
            showFilter?: boolean;
            showGrandTotals?: string;
            showHeaders?: boolean;
            showHierarchies?: boolean;
            showHierarchyCaptions?: boolean;
            showReportFiltersArea?: boolean;
            showTotals?: string;
            title?: string;
            type?: string;
            showAutoCalculationBar?: boolean;
            dragging?: boolean;
            grandTotalsPosition?: string;
            drillThroughMaxRows?: number;
        };
        filter?: {
            /**
             * @deprecated `timezoneOffset` was deprecated. Now filter adjusts to the time zone of the specific hierarchy.
             * The property will be eventually removed from the type definitions.
             */
            timezoneOffset?: number;
            weekOffset?: number;
            dateFormat?: string;
            liveSearch?: boolean;
        };
        allowBrowsersCache?: boolean;
        configuratorActive?: boolean;
        configuratorButton?: boolean;
        dateTimezoneOffset?: number;
        datePattern?: string;
        dateTimePattern?: string;
        defaultHierarchySortName?: string;
        drillThrough?: boolean;
        editing?: boolean;
        selectEmptyCells?: boolean;
        showAggregations?: boolean;
        showCalculatedValuesButton?: boolean;
        showDefaultSlice?: boolean;
        showMemberProperties?: boolean;
        sorting?: string | boolean;
        viewType?: string;
        showAggregationLabels?: boolean;
        useOlapFormatting?: boolean;
        defaultDateType?: string;
        timePattern?: string;
        showOutdatedDataAlert?: boolean;
        showEmptyData?: boolean;
        saveAllFormats?: boolean;
        showDrillThroughConfigurator?: boolean;
        grouping?: boolean;
        showAllFieldsDrillThrough?: boolean;
        validateFormulas?: boolean;
        showFieldListSearch?: boolean;
        strictDataTypes?: boolean;
        caseSensitiveMembers?: boolean;
        simplifyFieldListFolders?: boolean;
        validateReportFiles?: boolean;
        fieldListPosition?: string;
        showEmptyValues?: boolean | string;
        useCaptionsInCalculatedValueEditor?: boolean;
        expandExecutionTimeout?: number;
        readOnly?: boolean;
    }
 

Public
Nadia Khodakivska Nadia Khodakivska Flexmonster 1 day ago

Hello,

Thank you for the response.

We have noticed an inconsistency between the Flexmonster and the Angular wrapper drillThroughMaxRows property name. We will provide a fix with our minor release with the ETA September 5th. With this fix, the drillThroughMaxRows property should work as expected. Our team will notify you in case of any updates on the matter.

You are welcome to write to us in case further questions arise.

Kind regards,
Nadia

Please login or Register to Submit Answer