Get Free Trial

Help connecting to Microsoft Analysis Server 2019

Answered
Lane Hale asked on September 20, 2022

Hello,  we have a new server with an installation of Microsoft Analysis Server 2019.  We configured IIS and upgraded Flexmonster Pivot Table Component v2.4 and are receiving the message  ‘Invalid datasource or catalog. Please check.’
We followed the steps recommended using the OLAP connection tool.     We are able to get a Data Source option but no Catalogs and were hoping someone may have some advice for us.      We might have missed something in the configuration.
Attached is the OLAP connection attempt

 
Thank you kindly,  Lane Hale
Mutual of Enumclaw

Attachments:
OLAP Connection.docx

6 answers

Public
Maksym Diachenko Maksym Diachenko Flexmonster September 21, 2022

Hello,

Thank you for your question.

Based on the info from your screenshot, we understand that you are using a multidimensional cube and сonnecting via XMLA.

From our experience, such issues can happen due to various reasons related to msmdpump.dll configurations. As a simpler alternative to fixing the existing setup, we recommend using Flexmonster Accelerator – a proxy between the Flexmonster component and your Analysis Services instance. Changing the connection approach from XMLA to Flexmonster Accelerator may overcome existing connectivity issues. Also, it uses its own lightweight communication protocol to work with the component, improving the Flexmonster’s performance on the client’s machine. 

Please let us know if using Flexmonster Accelerator helps to resolve the "Invalid datasource or catalog" issue. 

Best Regards,
Maksym

Public
Lane Hale September 22, 2022

Thankyou Maksym for the recommendation for Accelerator.
We have installed the accelerator and seems to run and pass initial tests in the attached Flexmonster Accelerator Manager.doc.
Also attached is the xml for a SSAS cube we are trying to access called EDRR_Master.xml.
When we try to connect to the cube we get the error shown in attachment Error.doc and am suspecting we have missed something in the configuration?     Any other information I can provide I will be happy to send. 

Thank you,
Lane Hale
Mutual of Enumclaw

Public
Lane Hale September 22, 2022

I apologize the attachments did not take in the first reply

Public
Maksym Diachenko Maksym Diachenko Flexmonster September 23, 2022

Hello, 

Thank you for providing us with more details.

We have noticed that the proxyUrl parameter inside your report configuration is using HTTP (<proxyUrl>http://localhost:50005</proxyUrl>), while HTTPS is enabled in your Flexmonster Accelerator (TIME | TRACE | Server is running at http://localhost:50005).

We recommend changing proxyUrl to https://localhost:50005 or disabling HTTPS in the Flexmonster Accelerator configs so that proxyUrl is the same in the Accelerator and report. We also suggest updating Flexmonster to the latest version as well to make sure the Accelerator and Flexmonster are compatible with each other.

As a side note, we would like to mention that Flexmonster has been using JSON reports instead of XML since v2.3. Though XML reports are still backward compatible, we suggest switching to JSON reports. If you decide to migrate your XML reports to JSON, you can use our XML to JSON converter: https://www.flexmonster.com/blog/moving-to-json-converter-for-old-xml-reports/.

Please let us know if our recommendation helped to solve the connection issues.

Best Regards,
Maksym

Public
Lane Hale September 23, 2022

Thank you for the advice.    We now have the Protocol HTTP configured in both the Flexmonster Accelerator and the report configuration.
Also we had previously upgraded to Flexmonster Pivot Table 2.9 before installing Accelerator. Version attached.
We converted the report that we showed earlier to JSON attached called EDRR_Master.json. We changed EDRR_Master.html to call the json instead of xml.
We cleared cach and are now not receiving any error messages, just an emptry grid page.
We renamed the json expecting to revive a file not found and still received an empty page.

This leads us to think that we are not making any connection to the json file from the html file that access it. We are not sure but think we may have broken something.    

I will be back online on October 29th. Thanks in advance for any advice on this situation.
Lane Hale
Mutual of Enumclaw

Public
Maksym Diachenko Maksym Diachenko Flexmonster September 26, 2022

Hello, 

Thank you for your feedback.

As you mentioned in your reply, this issue may be caused by files not being correctly loaded. We recommend checking the browser’s stack trace so that it would be easier to identify the reason for the issue.

Also, we recommend using the new Flexmonster() constructor instead of the embedPivotComponent method as a newer approach for embedding the component into the HTML page. Please see the EDRR_Master.html file, modified to use the new Flexmonster() approach in the attachments.

Looking forward to hearing from you.

Best Regards,
Maksym

Attachments:
EDRR_Master.html

Please login or Register to Submit Answer