Get Free Trial
Get Free Trial

Only Count and DistinctCount aggregations are available

Answered
Hari7007 asked on November 13, 2019

Hi Team,
I have json data which has string and integer type values. When click on sigma icon in measure, it only show “Count” and “Distinct” aggregation.i want to convert integer values(seconds) to HH:MM:SS format.
here is my json data example:
“data”:[
{“Region”:”EUROPE”,
“Minutes”:”15:31″,
“Seconds”:55860}]
I want to convert Seconds into HH:MM:SS format and show the grand total of hours.
I have attached a file.Please Check it.

Attachments:
issue.JPG

6 answers

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster November 13, 2019

Hello,
 
Thank you for your question.
 
We kindly recommend finding out the time data type for JSON.
Learn more about JSON data types by following the link below: https://www.flexmonster.com/doc/data-types-in-json/.
 
Also, find out an example we made for you: https://jsfiddle.net/flexmonster/kfdaxyb3/.
 
Kind Regards,
Illia

Public
Hari7007 November 13, 2019

Thank You !! 🙂

Public
Hari7007 November 15, 2019

@ Illia Yatsyshyn : I have changed the type to ‘time’. But now i am facing issue in export excel 🙁 .Issue exists in the example that you have made for me https://jsfiddle.net/flexmonster/kfdaxyb3/. Please export as Excel and check the data.

Example : ’25:00:00′ shows as ‘1d 01:00:00 ‘in flexmonster report but in excel report it shows ’01:00:00’ 
I have attached an image for your reference.

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster November 15, 2019

Hello,
 
Thank you for reporting about that issue.
The fix will be released with the next minor update (ETA Dec 16).
 
For now, we can recommend using timePattern property as a workaround. It has to be adjusted inside the options object with the following value: "HHH:mm:ss".
Such an approach allows displaying hours quantity without dividing it on days in case there is more than 24 hours.
 
Check out an example we made for you: https://jsfiddle.net/flexmonster/kfdaxyb3/.
 
You are welcome to connect us in case of any additional questions appear.
 
Best Regards,
Illia

Public
Hari7007 November 18, 2019

Hello Illia Yatsyshyn,
Thank you for your quick response. Tried with “timePattern” option but still there is an issue with time objects. I am not getting exact sum of hours even after setting timePattern. I have attached an image for your reference. 
Note : Using Flexmonster Version 2.6.12

Attachments:
Timepattern Issue.png

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster November 18, 2019

Hello, 
 
Thank you for your feedback.
 
Our team didn’t manage to reproduce the issue with incorrect hours quantity displaying on the current version of Flexmonster.
 
We kindly recommend using the latest version of Flexmonster Pivot. You can find out how to update your component following the link below: https://www.flexmonster.com/doc/updating-to-the-latest-version/.
 
If that doesn’t help, we would like to kindly ask you to change the following fiddle so that the bug is reproducible: https://jsfiddle.net/flexmonster/kfdaxyb3/.
 
Feel free to contact us in case of additional questions.
 
Kind Regards,
Illia

Please login or Register to Submit Answer