Get Free Trial

Percent value in details pop-up for percent aggregation metric

Answered
Uladzislau Chernik asked on July 21, 2021

Hi support team,
I faced with issue when any percent aggregation applied to metric and metric formatted as percent, values in table formatted correctly (there isn’t multiplying by 100), but in header of the details pop-up value multiplied by 100 (see attachments). I would expect the same values for both table and details popup. Could you, please, explain is it a bug or specific logic?
Regards,
Uladzislau

Attachments:
popup.png
table.png

6 answers

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster July 22, 2021

Hello,
 
Thank you for posting on our forum.
 
Please note that using any percent aggregation implies that the measure should not be formatted as a percent. The percent symbol will be automatically added after applying aggregation.
Therefore, we recommend setting isPercent property to false or leaving it undefined.
 
If using isPercent: true is obligatory for your case for some reason, please explain its purpose.
 
Please let us know if it helps.
Looking forward to hearing from you.
 
Best regards,
Illia

Public
Uladzislau Chernik July 23, 2021

There is no real case, but there is such possibility to add metric with different aggregations and apply percent formatting. In this case everything works fine on table: percent aggregation showing just percentage, for other aggregations value is multiplied by 100 and percent symbol is added. But in details popup we see different result. For us it looks like inconsistency and it should not work such way. Do you plan to fix it?
 
Regards,
Uladzislau

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster July 26, 2021

Hello,

Thank you for describing your use case.
 
The fix is going to be provided with a minor update ETA Aug 26.
We will notify you as soon as the fixed version is available to download.
 
Feel free to reach out if other questions arise.
 
Kind regards,
Illia

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster August 25, 2021

Hello,
 
We are pleased to inform you that the issue with formatting % values in the drill-through view was fixed.
 
This is provided in the 2.9.6 version of Flexmonster: https://www.flexmonster.com/release-notes/.
 
You are welcome to update the component.
Here is our updating to the latest version tutorial for guidance: https://www.flexmonster.com/doc/updating-to-the-latest-version/.
 
Please let us know if everything works fine for you.
 
Best regards,
Illia

Public
Uladzislau Chernik August 31, 2021

Thank you a lot!
 
Regards,
Uladzislau

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster September 1, 2021

Hello, Uladzislau,
 
Thank you for your feedback.
 
Could you please confirm if the fix works well for you?
 
Looking forward to hearing from you.
 
Kind regards,
Illia

Please login or Register to Submit Answer