Get Free Trial
Get Free Trial

Problem to connect to elasticsearch

Resolved
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI asked on June 5, 2019

Hi,
I’m having some problems to create a report with a kind of data. The Flexmonster (version 2.7.3) keep on loading screen and the browser return some errors on the console.
 
ERROR

flexmonster.js.xhtml:9 Uncaught TypeError: B7k.Bf is not a function
at X7k.Ke (flexmonster.js.xhtml:9)
at X7k.aP (flexmonster.js.xhtml:9)
at flexmonster.js.xhtml:9
at i (elasticsearch.min.js?2.7.3:6)
at h (elasticsearch.min.js?2.7.3:6)
at XMLHttpRequest.d.onreadystatechange (elasticsearch.min.js?2.7.3:8)

DATA SAMPLE

{
"_index": "locomotive4",
"_type": "e",
"_id": "E81721242505168",
"_score": 0.001871863,
"_source": {
"loco": 8172,
"km": 0,
"speed": 0,
"vma": 0,
"press": 0,
"ibreak": 0,
"curr": 0,
"volt": 600,
"notch": 0,
"reverse": 0,
"buzzer": 0,
"bell": 0,
"isostate": 2,
"type": "E",
"dt": "2019/05/16 20:19:28",
"t": 1,
"block": null
}
}
,
{
"_index": "locomotive4",
"_type": "e",
"_id": "E81721242505171",
"_score": 0.001871863,
"_source": {
"loco": 8172,
"km": 0,
"speed": 0,
"vma": 0,
"press": 0,
"ibreak": 0,
"curr": 0,
"volt": 750,
"notch": 0,
"reverse": 0,
"buzzer": 0,
"bell": 0,
"isostate": 2,
"type": "E",
"dt": "2019/05/16 20:19:31",
"t": 1,
"block": null
}
}

4 answers

Public
Vera Didenko Flexmonster June 6, 2019

Hello, Mario,
 
Thank you for reaching out to us.
 
We kindly advise updating to the latest version of Flexmonster (2.7.7) since the issue may have been fixed there.
 
Please let us know if this works.
 
If this doesn’t resolve the issue, could you please provide a sample report where the issue is reproducible so we may help you solve this problem?
This will greatly help our team.
 
We are looking forward to hearing from you.
 
Best Regards,
Vera

Public
MARIO FRANCESCO VALENTINO CORREA CAVACIOCCHI June 6, 2019

Hi,
The problem happens with the field named “reverse” also the problem occurs with field named “length”. I’ve renamed on my elasticsearch and everything worked.
 
thx

Public
Vera Didenko Flexmonster June 7, 2019

Hello, Mario,
 
We are glad to hear that you managed to find a way to get everything working.
 
Thank you for sharing your solution with us.
 
Our team will look into this in more detail and we will notify you as soon as the reason for this will be found.
 
Please let us know if you have further questions.
 
Best Regards,
Vera

Public
Vera Didenko Flexmonster July 2, 2019

Hello, Mario,
 
 
We are glad to inform you that the issue with using specific field names (e.g. length, reverse, etc) in Elasticsearch was fixed.
 
This is available in the 2.7.9 version of Flexmonster: https://www.flexmonster.com/release-notes/
 
 
You are welcome to update the component: https://www.flexmonster.com/doc/updating-to-the-latest-version/ 
 
 
Please let us know if everything works fine for you.
 
Best Regards,
Vera

Please login or Register to Submit Answer