report filters ignoring MDX filtering

we have a problem with the amount of data the report filters are using.
the OLAP Cube we are using have products and sales and branches, both products and sales have link to a particular branch where they are used.
when creating the MDX we use a filter by branch that generates correctly the output with only data related to the branch we use in the MDX.
problem is starting when we try to use any of the filters in the generated report, they contain products for all branches not just the products returned by the MDX. (attached image is for report that have MDX filtering only London products but filter displays Vienna products also)
Is there any way to define how much and what data to be used by the report filters ?
 
best regards,
Nikolay

Attachments:
Clipboard01.jpg

3 answers

Public
Dmytro Zvazhii Flexmonster January 17, 2018

Hello Nikolay,
Thank you for your question. It seems that subquery property should solve the case. Please find more information in our docs – http://www.flexmonster.com/doc/data-source/?hilite=%22subquery%22 . Also, here is a jsfiddle example – http://jsfiddle.net/flexmonster/hcckvwx0/10/. As you can see, there is only the 2008 year available for filtering for the Delivery Date.Calendar field. 
Please let us know if the information above was helpful.
Regards,
Dmytro.

Public
Nikolay Petrov January 18, 2018

from the looks of it we need to add additional filtering by “Branch” for each dimension we use then the filter options in the report actually show only the data we need, we kinda hoped that we can filter the “Branch” dimension only and then all the rest of the dimensions having a link to the “Branch” dimension will be filtered automatically.
Anyway, works fain as is, just few additional lines to define filters.

Public
Dmytro Zvazhii Flexmonster January 19, 2018

Hello Nikolay,
Thank you for the update. We are glad that the case is seamed to be resolved.
Please let us know if there is anything else we can help you with.
Regards,
Dmytro.

Please login or Register to Submit Answer