Get Free Trial
Get Free Trial

Unable to plot a single measure chart when slice contains more than one active measure

Yousif Ahmed asked on July 24, 2019

Hi Flexmonster, 
I am having trouble plotting single measures on the chart view when the slice contains more than one active measure:
When the slice contains only one active measure, the chart plots both row and column fields, using a nice set of colours (see attached screenshot \’single_measure_in_slice.png\’). However, if the slice contains more than one active measure, the chart only plots the row fields and the first measure, using a single colour, in the same style as multiple measures mode.
Setting mutlipleMeasures to false and specifying the activeMeasure in the chart options seems to have no effect (see attached screenshot \’two_measures_in_slice.png\’). The only way to achieve the single measure chart is to set active = false for all but one of the measures. Unfortunately this also hides the measure from the grid view, which is a problem when viewing both the grid and charts together.
Even if there are two active measures in the slice, since only one measure is being displayed at a time and the options.chart.activeMeasure is defined, we would expect to see the regular chart with both rows and columns plotted (as in \’single_measure_in_slice.png\’), and be able to select the displayed measure from the dropdown list.
It seems as though this is a bug – perhaps the chart options multipleMeasures and activeMeasure are overridden by or conflicting with what is defined in the slice? I cannot see a reason why having multiple measures in the slice alters the chart in this way even when only one measure is being displayed at a time…
Can you think of a way to achieve this without running two instances of the pivot with different slices? Our datasets are often very large and so duplicating is not a viable option. Kind Regards, Yousif

2 answers

Public
Vera Didenko Flexmonster July 24, 2019

Hello, Yousif,
 
Thank you for pointing this out to us.
 
Our team will provide a fix to this issue in the minor release version with the ETA 12th of August.
 
You are welcome to contact us in case any questions arise.
 
Best Regards,
Vera

Public
Vera Didenko Flexmonster August 14, 2019

Hello, Yousif,
 
We are happy to let you know that the issue when a legend on charts is not shown if a slice contains more than one measure was fixed.
 
This is included in the 2.7.12 version of Flexmonster: https://www.flexmonster.com/release-notes/
 
You are welcome to update the component.
Here is our updating to the latest version tutorial for guidance: https://www.flexmonster.com/doc/updating-to-the-latest-version/ 
 
Please let us know if everything works fine for you.
 
Best Regards,
Vera

Please login or Register to Submit Answer