Despite the COVID-19 outbreak, our team continues operating at full speed. We are always here to support and answer all your questions.

Feel free to reach out by filling this quick form.

Fill the form
Get Free Trial

Undefined when I update the version

Answered
dongbeom Kim asked on August 11, 2020
The currently used version is as follows.
package.json attachment

{
"name": "angular-starter",
"version": "6.0.0",
"description": "An Angular Webpack Starter kit featuring Angular (Router, Http, Forms, Services, Tests, E2E, Coverage), Karma, Protractor, Jasmine, Istanbul, TypeScript, and Webpack by AngularClass",
"keywords": [
"angular",
"angular2",
"angular4",
"webpack",
"typescript"
],
"author": "Patrick Stapleton <patrick@angularclass.com>",
"homepage": "https://github.com/AngularClass/angular-starter",
"license": "MIT",
"dependencies": {
"@angular/animations": "~4.3.1",
"@angular/common": "~4.3.1",
"@angular/compiler": "~4.3.1",
"@angular/core": "~4.3.1",
"@angular/forms": "~4.3.1",
"@angular/http": "~4.3.1",
"@angular/platform-browser": "~4.3.1",
"@angular/platform-browser-dynamic": "~4.3.1",
"@angular/platform-server": "~4.3.1",
"@angular/router": "~4.3.1",
"@angularclass/hmr": "~1.2.2",
"@angularclass/hmr-loader": "^3.0.4",
"@types/flexmonster": "^2.7.1",
"ag-grid": "8.2.x",
"ag-grid-angular": "8.2.x",
"ag-grid-enterprise": "8.2.x",
"angular-2-local-storage": "1.0.1",
"angular-webstorage-service": "^1.0.2",
"assets-webpack-plugin": "^3.5.1",
"bootstrap": "3.3.6",
"core-js": "^2.4.1",
"file-saver": "1.3.3",
"flexmonster": "^2.8.13",
"http-server": "^0.9.0",
"ie-shim": "^0.1.0",
"jquery": "^2.2.3",
"jstz": "1.0.7",
"lodash": "^4.13.1",
"moment": "^2.14.1",
"ng-flexmonster": "^2.8.9",
"ng2-bootstrap": "1.1.7",
"ng2-daterangepicker": "^2.0.12",
"ng2-table": "^1.3.2",
"ng2-translate": "5.0.0",
"ngx-zendesk-webwidget": "0.1.2",
"reflect-metadata": "^0.1.10",
"rxjs": "~5.5.5",
"xlsx": "0.11.16",
"zone.js": "0.8.14"
},
"devDependencies": {
"@angular/compiler-cli": "~4.3.1",
"@types/hammerjs": "^2.0.34",
"@types/jasmine": "2.5.45",
"@types/node": "^7.0.39",
"@types/source-map": "^0.5.0",
"@types/uglify-js": "^2.6.28",
"@types/webpack": "^2.2.16",
"add-asset-html-webpack-plugin": "^1.0.2",
"angular2-template-loader": "^0.6.2",
"assets-webpack-plugin": "^3.5.1",
"awesome-typescript-loader": "~3.1.2",
"codelyzer": "~2.1.1",
"copy-webpack-plugin": "^4.0.1",
"cross-env": "^5.0.0",
"css-loader": "^0.28.0",
"exports-loader": "^0.6.4",
"expose-loader": "^0.7.3",
"extract-text-webpack-plugin": "~2.1.0",
"file-loader": "^0.11.1",
"find-root": "^1.0.0",
"gh-pages": "^1.0.0",
"html-webpack-plugin": "^2.28.0",
"imports-loader": "^0.7.1",
"inline-manifest-webpack-plugin": "^3.0.1",
"istanbul-instrumenter-loader": "2.0.0",
"jasmine-core": "^2.5.2",
"karma": "^1.6.0",
"karma-chrome-launcher": "^2.0.0",
"karma-coverage": "^1.1.1",
"karma-jasmine": "^1.1.0",
"karma-mocha-reporter": "^2.2.3",
"karma-remap-coverage": "^0.1.4",
"karma-sourcemap-loader": "^0.3.7",
"karma-webpack": "^2.0.4",
"ng-router-loader": "^2.1.0",
"ngc-webpack": "^3.2.0",
"node-sass": "^4.13.0",
"npm-run-all": "^4.0.2",
"optimize-js-plugin": "0.0.4",
"parse5": "^3.0.2",
"preload-webpack-plugin": "^1.2.2",
"protractor": "^5.1.1",
"raw-loader": "0.5.1",
"rimraf": "~2.6.1",
"sass-loader": "^6.0.3",
"script-ext-html-webpack-plugin": "^1.8.5",
"source-map-loader": "^0.2.1",
"string-replace-loader": "~1.2.0",
"style-loader": "^0.18.1",
"to-string-loader": "^1.1.5",
"ts-node": "^3.3.0",
"tslib": "^1.7.1",
"tslint": "~4.5.1",
"tslint-loader": "^3.5.2",
"typedoc": "^0.7.1",
"typescript": "~2.2.2",
"url-loader": "^0.5.8",
"webpack": "~2.6.1",
"webpack-dev-middleware": "^1.10.1",
"webpack-dev-server": "^2.4.2",
"webpack-dll-bundles-plugin": "^1.0.0-beta.5",
"webpack-merge": "~4.1.0"
},
"repository": {
"type": "git",
"url": "https://github.com/AngularClass/angular-starter.git"
},
"bugs": {
"url": "https://github.com/AngularClass/angular-starter/issues"
},
"engines": {
"node": ">= 4.2.1",
"npm": ">= 3"
}
}

I want to update the version to use dataserver.
https://www.flexmonster.com/doc/updating-to-the-latest-version/

Even if you follow everything on that page Flexmonster is not defined I get an error.
What is the problem and what steps should be taken?

When I ran npm update flexmonster --save and ran it with version 2.8.13, the error was attached to the picture.



4 answers

Public
dongbeom Kim August 11, 2020
the error was attached to the picture.

Attachments:
dataserverError.png

Public
dongbeom Kim August 11, 2020

node -v 12.15.0, npm -v 6.13.7

Public
dongbeom Kim August 11, 2020

NOTE: Being our active customer (during the first year after purchase or renewal payment) you are able to update for free. If you are our client and you would like to renew the maintenance, please contact us for more details.
 
In addition, does this mean that it is impossible to update the version after 1 year of purchasing the license?

Public
Illia Yatsyshyn Illia Yatsyshyn Flexmonster August 12, 2020

Hello,
 
Thank you for reaching out to us.
 
Our team wants to kindly inform you that we did not manage to reproduce the described problem.
Therefore we would like to ask you for a sample where the issue could be noticed. We suggest modifying our GitHub example demonstrating integration with Angular in the way the problem is reproducible.
 
As for your question regarding the maintenance renewal.
You can update the license version to the latest version that is available under your license maintenance. Hence, even if your maintenance is already expired you can still update your license version to the version that was supported by your maintenance till its expiration date.
 
Our team is looking forward to hearing from you.
Do not hesitate to contact us in case other questions arise.
 
Kind regards,
Illia

Please login or Register to Submit Answer