Stream error occurred while loading ‘http://localhost:50005’

Hi,
I’m getting error while trying to connect to MS SSAS cube. I tried the steps mentioned in the below link but it didn’t work.
https://www.flexmonster.com/question/stream-error-occurred-while-loading-httplocalhost8080olapmsmdpump-dll/
In my web page where flexmonster is placed it shows:
 

Stream error occurred while loading ‘http://localhost:50005

Read more info about this error
OK

and then it shows alert popup saying: Flexmonster: Pivot cannot be drawn.
The accelerator is up and running and I’m able to navigate to http://localhost:50005
In browser console the errors I see is:
SEC7120: Origin http://localhost:60415 not found in Access-Control-Allow-Origin header.
SCRIPT7002: XMLHttpRequest: Network Error 0x80070005, Access is denied.
Flexmonster: Pivot cannot be drawn.
 
I added <add name=Access-Control-Allow-Origin value=* />
in web.config of the application but still same error.
 

3 answers

Public
Dmytro Zvazhii Flexmonster July 30, 2018

Hello Raj,
Thank you for your question. It seems that the binary property is not set when configuring pivot. Please set "binary": true when connecting to accelerator with the Flexmonster pivot. Here is the example:
report: {
...
   dataSource: {
      ...
      binary: true
   }
...
}
Please let us know if the information above was helpful for you.
Regards,
Dmytro

Public
Raj July 31, 2018

Hi Dmytro,
Thanks for your response. I had binary: true earlier but because I kept getting error I was trying out without it.
When I add binary: true, in browser console I see “XMLHttpRequest: Network Error 0x80070005, Access is denied.” and get Error popup Unknown error occurred. on FlexMonster control.
The application and SSAS are in my local machine so not sure why I get Access denied error.

Public
Iryna Kulchytska Flexmonster August 2, 2018

Hi Raj,
 
The property "binary": true is required in the report when using the accelerator to connect Flexmonster pivot table to SSAS.
Please use it in your report as Dmytro recommended you in the previous message.
 
Here are our further recommendations:
 

  1. “XMLHttpRequest: Network Error 0x80070005, Access is denied.” looks like the CORS issue. Could you please double-check if you enabled CORS on your server properly? Have a look at the following article about CORS configuration: https://enable-cors.org/server.html.
  2. Make sure that the accelerator is running on the same port which is set in proxyUrl parameter of your report. Also, please check that this port is opened in the firewall.
  3. Check the content of flexmonster.log.txt file to see if you find any errors here.
  4. If none of the above helps, please provide us with your flexmonster.config for the accelerator and your flexmonster.log.txt file.

 
Please let us know the status.
 
Kind regards,
Iryna
 

Please login or Register to Submit Answer